On 2024-06-13 20:05:04, Dmitry Baryshkov wrote: > Command mode panels provide TE signal back to the DSI host to signal > that the frame display has completed and update of the image will not > cause tearing. Usually it is connected to the first GPIO with the > mdp_vsync function, which is the default. In such case the property can > be skipped. > > Acked-by: Krzysztof Kozlowski <krzysztof.kozlowski@xxxxxxxxxx> > Reviewed-by: Rob Herring (Arm) <robh@xxxxxxxxxx> > Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@xxxxxxxxxx> > --- > .../bindings/display/msm/dsi-controller-main.yaml | 17 +++++++++++++++++ > 1 file changed, 17 insertions(+) > > diff --git a/Documentation/devicetree/bindings/display/msm/dsi-controller-main.yaml b/Documentation/devicetree/bindings/display/msm/dsi-controller-main.yaml > index 1fa28e976559..e1cb3a1fee81 100644 > --- a/Documentation/devicetree/bindings/display/msm/dsi-controller-main.yaml > +++ b/Documentation/devicetree/bindings/display/msm/dsi-controller-main.yaml > @@ -162,6 +162,22 @@ properties: > items: > enum: [ 0, 1, 2, 3 ] > > + qcom,te-source: > + $ref: /schemas/types.yaml#/definitions/string > + description: > + Specifies the source of vsync signal from the panel used for > + tearing elimination. > + default: mdp_vsync_p > + enum: > + - mdp_vsync_p > + - mdp_vsync_s > + - mdp_vsync_e When discussing that these should be renamed, was it also documented what the suffix means? I can only guess something like primary/secondary/e...? Are the mdp_intfX variants missing here that you're handling in patch 7/8? > + - timer0 > + - timer1 > + - timer2 > + - timer3 > + - timer4 > + > required: > - port@0 > - port@1 > @@ -452,6 +468,7 @@ examples: > dsi0_out: endpoint { > remote-endpoint = <&sn65dsi86_in>; > data-lanes = <0 1 2 3>; > + qcom,te-source = "mdp_vsync_e"; > }; > }; > }; > > -- > 2.39.2 >