Re: [PATCH v2 3/3] Input: ektf2127 - add ektf2232 support

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, 6 May 2024 15:05:52 +0300
Andy Shevchenko <andy.shevchenko@xxxxxxxxx> wrote:

> From: Andy Shevchenko <andy.shevchenko@xxxxxxxxx>
> To: Andreas Kemnade <andreas@xxxxxxxxxxxx>
> Cc: dmitry.torokhov@xxxxxxxxx, robh@xxxxxxxxxx, krzk+dt@xxxxxxxxxx,   conor+dt@xxxxxxxxxx, u.kleine-koenig@xxxxxxxxxxxxxx, hdegoede@xxxxxxxxxx,   siebren.vroegindeweij@xxxxxxxxxxx, linux-input@xxxxxxxxxxxxxxx,   devicetree@xxxxxxxxxxxxxxx, linux-kernel@xxxxxxxxxxxxxxx
> Subject: Re: [PATCH v2 3/3] Input: ektf2127 - add ektf2232 support
> Date: Mon, 6 May 2024 15:05:52 +0300
> 
> On Mon, May 6, 2024 at 12:48 AM Andreas Kemnade <andreas@xxxxxxxxxxxx> wrote:
> >
> > The chip is similar, but has status bits at different positions,
> > so use the correct bits.  
> 
> ...
> 
> > @@ -46,6 +47,11 @@ struct ektf2127_ts {
> >         struct input_dev *input;
> >         struct gpio_desc *power_gpios;
> >         struct touchscreen_properties prop;
> > +       int status_shift;
> > +};
> > +
> > +struct ektf2127_i2c_chip_data {
> > +       int status_shift;
> >  };
> >
> >  static void ektf2127_parse_coordinates(const u8 *buf, unsigned int touch_count,  
> 
> I'm wondering if you are using --histogram diff algo when preparing the patches.

No, I am not using that, it seems to not make that chunk nicer. 
Yes, we want

+       int status_shift;
 };
+
+struct ektf2127_i2c_chip_data {
+       int status_shift;
+};

But that is not shorter or simpler, just more readable.

Regards,
Andreas





[Index of Archives]     [Device Tree Compilter]     [Device Tree Spec]     [Linux Driver Backports]     [Video for Linux]     [Linux USB Devel]     [Linux PCI Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Yosemite Backpacking]


  Powered by Linux