On Mon, 25 Mar 2024 15:33:51 +0000 Lothar Rubusch <l.rubusch@xxxxxxxxx> wrote: > In the probe function group bus configuration and the > indio_dev initialization to improve readability. > > Signed-off-by: Lothar Rubusch <l.rubusch@xxxxxxxxx> > --- > drivers/iio/accel/adxl345_core.c | 13 +++++++------ > 1 file changed, 7 insertions(+), 6 deletions(-) > > diff --git a/drivers/iio/accel/adxl345_core.c b/drivers/iio/accel/adxl345_core.c > index be6758015..469015e9c 100644 > --- a/drivers/iio/accel/adxl345_core.c > +++ b/drivers/iio/accel/adxl345_core.c > @@ -218,22 +218,23 @@ int adxl345_core_probe(struct device *dev, struct regmap *regmap) > > data = iio_priv(indio_dev); > data->regmap = regmap; > - /* Enable full-resolution mode */ The naming of the written value gives this comment away + it's obviously misplaced after previous patch. I'd just drop the comment in patch 1. > + > data->info = device_get_match_data(dev); > if (!data->info) > return -ENODEV; > > - ret = regmap_update_bits(regmap, ADXL345_REG_DATA_FORMAT, > - ADXL345_DATA_FORMAT_MSK, ADXL345_DATA_FORMAT_FULL_RES); > - if (ret) > - return dev_err_probe(dev, ret, "Failed to set data range\n"); > - > indio_dev->name = data->info->name; > indio_dev->info = &adxl345_info; > indio_dev->modes = INDIO_DIRECT_MODE; > indio_dev->channels = adxl345_channels; > indio_dev->num_channels = ARRAY_SIZE(adxl345_channels); > > + /* Enable full-resolution mode */ > + ret = regmap_update_bits(regmap, ADXL345_REG_DATA_FORMAT, > + ADXL345_DATA_FORMAT_MSK, ADXL345_DATA_FORMAT_FULL_RES); > + if (ret) > + return dev_err_probe(dev, ret, "Failed to set data range\n"); > + > /* Enable measurement mode */ > ret = adxl345_powerup(data->regmap); > if (ret < 0)