On Sun, Mar 24, 2024 at 2:32 PM Jonathan Cameron <jic23@xxxxxxxxxx> wrote: > > On Sat, 23 Mar 2024 12:20:27 +0000 > Lothar Rubusch <l.rubusch@xxxxxxxxx> wrote: > > > Add a setup function implementation to the spi module to enable > > spi-3wire as option when specified in the device-tree. > > > > Signed-off-by: Lothar Rubusch <l.rubusch@xxxxxxxxx> > > --- > > drivers/iio/accel/adxl345.h | 3 +++ > > drivers/iio/accel/adxl345_spi.c | 12 +++++++++++- > > 2 files changed, 14 insertions(+), 1 deletion(-) > > > > diff --git a/drivers/iio/accel/adxl345.h b/drivers/iio/accel/adxl345.h > > index 3c1ded0c2..6b84a2cee 100644 > > --- a/drivers/iio/accel/adxl345.h > > +++ b/drivers/iio/accel/adxl345.h > > @@ -8,6 +8,9 @@ > > #ifndef _ADXL345_H_ > > #define _ADXL345_H_ > > > > +#define ADXL345_REG_DATA_FORMAT 0x31 > > +#define ADXL345_DATA_FORMAT_SPI BIT(6) /* spi-3wire */ > Name it that, rather than using a comment. No need to precisely > match datasheet naming - you are naming the value not the field here. > > ADXL345_DATA_FORMAT_SPI_3_WRITE perhaps? > Would you accept the following instead? ADXL345_DATA_FORMAT_SPI_3WIRE In the OF binding it is SPI_3WIRE. So, from this perspective I think it would be consistent naming. (...)