On 8.03.2024 01:37, Justin Swartz wrote:
Add default #address-cells and #size-cells properties to the usb node, which should be suitable for hubs and devices without explicitly declared interface nodes, as: "#address-cells": description: should be 1 for hub nodes with device nodes, should be 2 for device nodes with interface nodes. enum: [1, 2] "#size-cells": const: 0 -- Documentation/devicetree/bindings/usb/usb-device.yaml This version of the patch places the properties according to the order recommended by: Documentation/devicetree/bindings/dts-coding-style.rst Signed-off-by: Justin Swartz <justin.swartz@xxxxxxxxxxxxxxxx> --- arch/mips/boot/dts/ralink/mt7621.dtsi | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/arch/mips/boot/dts/ralink/mt7621.dtsi b/arch/mips/boot/dts/ralink/mt7621.dtsi index 5a89f0b8c..7532e17dd 100644 --- a/arch/mips/boot/dts/ralink/mt7621.dtsi +++ b/arch/mips/boot/dts/ralink/mt7621.dtsi @@ -289,10 +289,10 @@ usb: usb@1e1c0000 { reg = <0x1e1c0000 0x1000 0x1e1d0700 0x0100>; reg-names = "mac", "ippc"; - + #address-cells = <1>; + #size-cells = <0>; clocks = <&sysc MT7621_CLK_XTAL>; clock-names = "sys_ck"; -
Please keep the empty lines. It's easier to read. I don't see anything on the Devicetree Sources (DTS) Coding Style that would restrict this. Arınç