On 19.01.24 08:43, Javier Carrasco wrote: > Some touchscreens are shipped with a physical layer on top of them where > a number of buttons and a resized touchscreen surface might be available. > > In order to generate proper key events by overlay buttons and adjust the > touch events to a clipped surface, this series offers a documented, > device-tree-based solution by means of helper functions. > An implementation for a specific touchscreen driver is also included. > > The functions in touch-overlay provide a simple workflow to acquire > physical objects from the device tree, map them into a list and generate > events according to the object descriptions. > > This feature has been tested with a JT240MHQS-E3 display, which consists > of an st1624 as the base touchscreen and an overlay with two buttons and > a frame that clips its effective surface mounted on it. > > Signed-off-by: Javier Carrasco <javier.carrasco@xxxxxxxxxxxxxx> > --- > Changes in v7: > - General: return to a single input device implementation. > - touchscreen bindings: segment instead of button in the label > description. > - touch-overlay.c: define button-specific data inside segment struct. > - touch-overlay.c: remove fwnode_property_present() and check return > value of fwnode_property_read_u32() in touch_overlay_get_segment(). > - touch-overlay.c: simplify return path in touch_overlay_map(). > - Link to v6: https://lore.kernel.org/r/20230510-feature-ts_virtobj_patch-v6-0-d8a605975153@xxxxxxxxxxxxxx > > Changes in v6: > - General: use a single list to manage a single type of object. > - General: swap patches to have bindings preceding the code. > - touch-overlay.c: minor code-sytle fixes. > - Link to v5: https://lore.kernel.org/r/20230510-feature-ts_virtobj_patch-v5-0-ff6b5c4db693@xxxxxxxxxxxxxx > > Changes in v5: > - touchscreen bindings: move overlay common properties to a $def entry (Rob Herring) > - st1232 bindings: move overlays to the existing example instead of > making a new one (Rob Herring) > - Link to v4: https://lore.kernel.org/r/20230510-feature-ts_virtobj_patch-v4-0-5c6c0fc1eed6@xxxxxxxxxxxxxx > > Changes in v4: > - General: rename "touchscreen" to "touch" to include other consumers. > - PATCH 1/4: move touch-overlay feature to input core. > - PATCH 1/4, 3/4: set key caps and report key events without consumer's > intervention. > - PATCH 2/4: add missing 'required' field with the required properties. > - Link to v3: https://lore.kernel.org/r/20230510-feature-ts_virtobj_patch-v3-0-b4fb7fc4bab7@xxxxxxxxxxxxxx > > Changes in v3: > - General: rename "virtobj" and "virtual" to "overlay" > - PATCH 1/4: Make feature bool instead of tristate (selected by > supported touchscreens) > - Link to v2: https://lore.kernel.org/r/20230510-feature-ts_virtobj_patch-v2-0-f68a6bfe7a0f@xxxxxxxxxxxxxx > > Changes in v2: > - PATCH 1/4: remove preprocessor directives (the module is selected by > the drivers that support the feature). Typo in the commit message. > - PATCH 2/4: more detailed documentation. Images and examples were added. > - PATCH 3/4: select ts-virtobj automatically. > - Link to v1: https://lore.kernel.org/r/20230510-feature-ts_virtobj_patch-v1-0-5ae5e81bc264@xxxxxxxxxxxxxx > > --- > Javier Carrasco (4): > dt-bindings: touchscreen: add touch-overlay property > Input: touch-overlay - Add touchscreen overlay handling > dt-bindings: input: touchscreen: st1232: add touch-overlay example > Input: st1232 - add touch overlays handling > > .../input/touchscreen/sitronix,st1232.yaml | 29 +++ > .../bindings/input/touchscreen/touchscreen.yaml | 119 ++++++++++ > MAINTAINERS | 7 + > drivers/input/Makefile | 2 +- > drivers/input/touch-overlay.c | 250 +++++++++++++++++++++ > drivers/input/touchscreen/st1232.c | 48 ++-- > include/linux/input/touch-overlay.h | 22 ++ > 7 files changed, 462 insertions(+), 15 deletions(-) > --- > base-commit: 0dd3ee31125508cd67f7e7172247f05b7fd1753a > change-id: 20230510-feature-ts_virtobj_patch-e267540aae74 > > Best regards, Gentle ping. Best regards, Javier Carrasco