Re: [PATCH v1 1/3] dt-bindings: drm: rockchip: convert inno_hdmi-rockchip.txt to yaml

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi,

On 12/4/23 19:56, Alex Bee wrote:
> Hi Johan,
> Am 04.12.23 um 18:39 schrieb Johan Jonker:
>> Convert inno_hdmi-rockchip.txt to yaml.
> Nice - I'm having something very similar on my queue :)
>>
>> Signed-off-by: Johan Jonker <jbx6244@xxxxxxxxx>
>> ---
>>
>> Note for rob+dt:
>>    Used enum to "soon" be able to add "rockchip,rk3128-inno-hdmi"

> Yeah, actually I'm planning to submit it really soon (if timne allows).

;)

>>
>> Changed V1:
>>    Rename file to more common layout
>>    Add/fix hdmi_out port example
>> ---
>>   .../display/rockchip/inno_hdmi-rockchip.txt   |  49 ---------
>>   .../display/rockchip/rockchip,inno-hdmi.yaml  | 103 ++++++++++++++++++
>>   2 files changed, 103 insertions(+), 49 deletions(-)
>>   delete mode 100644 Documentation/devicetree/bindings/display/rockchip/inno_hdmi-rockchip.txt
>>   create mode 100644 Documentation/devicetree/bindings/display/rockchip/rockchip,inno-hdmi.yaml
>>
>> diff --git a/Documentation/devicetree/bindings/display/rockchip/inno_hdmi-rockchip.txt b/Documentation/devicetree/bindings/display/rockchip/inno_hdmi-rockchip.txt
>> deleted file mode 100644
>> index cec21714f0e0..000000000000
>> --- a/Documentation/devicetree/bindings/display/rockchip/inno_hdmi-rockchip.txt
>> +++ /dev/null
>> @@ -1,49 +0,0 @@
>> -Rockchip specific extensions to the Innosilicon HDMI
>> -================================
>> -
>> -Required properties:
>> -- compatible:
>> -    "rockchip,rk3036-inno-hdmi";
>> -- reg:
>> -    Physical base address and length of the controller's registers.
>> -- clocks, clock-names:
>> -    Phandle to hdmi controller clock, name should be "pclk"
>> -- interrupts:
>> -    HDMI interrupt number
>> -- ports:
>> -    Contain one port node with endpoint definitions as defined in
>> -    Documentation/devicetree/bindings/graph.txt.
>> -- pinctrl-0, pinctrl-name:
>> -    Switch the iomux of HPD/CEC pins to HDMI function.
>> -
>> -Example:
>> -hdmi: hdmi@20034000 {
>> -    compatible = "rockchip,rk3036-inno-hdmi";
>> -    reg = <0x20034000 0x4000>;
>> -    interrupts = <GIC_SPI 45 IRQ_TYPE_LEVEL_HIGH>;
>> -    clocks = <&cru  PCLK_HDMI>;
>> -    clock-names = "pclk";
>> -    pinctrl-names = "default";
>> -    pinctrl-0 = <&hdmi_ctl>;
>> -
>> -    hdmi_in: port {
>> -        #address-cells = <1>;
>> -        #size-cells = <0>;
>> -        hdmi_in_lcdc: endpoint@0 {
>> -            reg = <0>;
>> -            remote-endpoint = <&lcdc_out_hdmi>;
>> -        };
>> -    };
>> -};
>> -
>> -&pinctrl {
>> -    hdmi {
>> -        hdmi_ctl: hdmi-ctl {
>> -            rockchip,pins = <1 8  RK_FUNC_1 &pcfg_pull_none>,
>> -                    <1 9  RK_FUNC_1 &pcfg_pull_none>,
>> -                    <1 10 RK_FUNC_1 &pcfg_pull_none>,
>> -                    <1 11 RK_FUNC_1 &pcfg_pull_none>;
>> -        };
>> -    };
>> -
>> -};
>> diff --git a/Documentation/devicetree/bindings/display/rockchip/rockchip,inno-hdmi.yaml b/Documentation/devicetree/bindings/display/rockchip/rockchip,inno-hdmi.yaml
>> new file mode 100644
>> index 000000000000..96889c86849a
>> --- /dev/null
>> +++ b/Documentation/devicetree/bindings/display/rockchip/rockchip,inno-hdmi.yaml
>> @@ -0,0 +1,103 @@
>> +# SPDX-License-Identifier: GPL-2.0
>> +%YAML 1.2
>> +---
>> +$id: http://devicetree.org/schemas/display/rockchip/rockchip,inno-hdmi.yaml#
>> +$schema: http://devicetree.org/meta-schemas/core.yaml#
>> +
>> +title: Rockchip Innosilicon HDMI controller
>> +
>> +maintainers:
>> +  - Sandy Huang <hjc@xxxxxxxxxxxxxx>
>> +  - Heiko Stuebner <heiko@xxxxxxxxx>
>> +
>> +properties:
>> +  compatible:
>> +    enum:
>> +      - rockchip,rk3036-inno-hdmi
>> +
>> +  reg:
>> +    maxItems: 1
>> +
>> +  interrupts:
>> +    maxItems: 1
>> +
>> +  clocks:
>> +    maxItems: 1

> The interrupts/clock description exists already in the txt-bindings - so how about:
> 
> +    items:
> +      - descrition: ....
>> +

It's not common to do so when there's only one clock and nothing special to mention.
Used this style for most of my conversions. 
Further rational might be given by Krzysztof and co.

>> +  clock-names:
>> +    const: pclk
>> +
>> +  ports:
>> +    $ref: /schemas/graph.yaml#/properties/ports
>> +
>> +    properties:
>> +      port@0:
>> +        $ref: /schemas/graph.yaml#/properties/port
>> +        description:
>> +          Port node with one endpoint connected to a vop node.
>> +
>> +      port@1:
>> +        $ref: /schemas/graph.yaml#/properties/port
>> +        description:
>> +          Port node with one endpoint connected to a hdmi-connector node.
>> +
>> +    required:
>> +      - port@0
>> +      - port@1
>> +
>> +required:
>> +  - compatible
>> +  - reg
>> +  - interrupts
>> +  - clocks
>> +  - clock-names
>> +  - pinctrl-0
>> +  - pinctrl-names
>> +  - ports
>> +
>> +additionalProperties: false

> Did you check that with dtbs_check? RK3036's SoC dtsi also contains a
> 
>  rockchip,grf = <&grf>;
> 
> and I'm not seeing this removed in this series.
> 

I did check. Currently grf is not used in a mainline driver and only in the Rockchip tree.
Choose to keep it as it is for now.

> It would be great if that would added here to as requirement
> for RK3036 too  (and updated in the example)
> Even if it is beyond a pure txt to yaml conversion: RK3036 needs to set HDMI polarities in GRF.

It's a good habit to do one action per patch. In this case we convert an exciting document.
Everyone is free to add further properties if needed.

Johan


> 
> Regards,
> Alex
>> +
>> +examples:
>> +  - |
>> +    #include <dt-bindings/clock/rk3036-cru.h>
>> +    #include <dt-bindings/interrupt-controller/arm-gic.h>
>> +    #include <dt-bindings/pinctrl/rockchip.h>
>> +    hdmi: hdmi@20034000 {
>> +      compatible = "rockchip,rk3036-inno-hdmi";
>> +      reg = <0x20034000 0x4000>;
>> +      interrupts = <GIC_SPI 45 IRQ_TYPE_LEVEL_HIGH>;
>> +      clocks = <&cru  PCLK_HDMI>;
>> +      clock-names = "pclk";
>> +      pinctrl-names = "default";
>> +      pinctrl-0 = <&hdmi_ctl>;
>> +
>> +      ports {
>> +        #address-cells = <1>;
>> +        #size-cells = <0>;
>> +
>> +        hdmi_in: port@0 {
>> +          reg = <0>;
>> +          hdmi_in_vop: endpoint {
>> +            remote-endpoint = <&vop_out_hdmi>;
>> +          };
>> +        };
>> +
>> +        hdmi_out: port@1 {
>> +          reg = <1>;
>> +          hdmi_out_con: endpoint {
>> +            remote-endpoint = <&hdmi_con_in>;
>> +          };
>> +        };
>> +      };
>> +    };
>> +
>> +    pinctrl {
>> +      hdmi {
>> +        hdmi_ctl: hdmi-ctl {
>> +          rockchip,pins = <1 RK_PB0 1 &pcfg_pull_none>,
>> +                          <1 RK_PB1 1 &pcfg_pull_none>,
>> +                          <1 RK_PB2 1 &pcfg_pull_none>,
>> +                          <1 RK_PB3 1 &pcfg_pull_none>;
>> +        };
>> +      };
>> +    };
>> -- 
>> 2.39.2
>>
>>
>> _______________________________________________
>> Linux-rockchip mailing list
>> Linux-rockchip@xxxxxxxxxxxxxxxxxxx
>> http://lists.infradead.org/mailman/listinfo/linux-rockchip
> 




[Index of Archives]     [Device Tree Compilter]     [Device Tree Spec]     [Linux Driver Backports]     [Video for Linux]     [Linux USB Devel]     [Linux PCI Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Yosemite Backpacking]


  Powered by Linux