Hello Conor, thanks for the review. On Mon, Nov 13, 2023 at 07:55:20PM +0000, Conor Dooley wrote: > On Mon, Nov 13, 2023 at 03:59:20PM +0100, Francesco Dolcini wrote: > > From: Stefan Eichenberger <stefan.eichenberger@xxxxxxxxxxx> > > > > The USB5744 has two power supplies one for 3V3 and one for 1V2. Add the > > second supply to the USB5744 DT binding. > > > > Signed-off-by: Stefan Eichenberger <stefan.eichenberger@xxxxxxxxxxx> > > Signed-off-by: Francesco Dolcini <francesco.dolcini@xxxxxxxxxxx> > > --- > > .../devicetree/bindings/usb/microchip,usb5744.yaml | 7 ++++++- > > 1 file changed, 6 insertions(+), 1 deletion(-) > > > > diff --git a/Documentation/devicetree/bindings/usb/microchip,usb5744.yaml b/Documentation/devicetree/bindings/usb/microchip,usb5744.yaml > > index ff3a1707ef57..6d4cfd943f58 100644 > > --- a/Documentation/devicetree/bindings/usb/microchip,usb5744.yaml > > +++ b/Documentation/devicetree/bindings/usb/microchip,usb5744.yaml > > @@ -36,7 +36,11 @@ properties: > > > > vdd-supply: > > description: > > - VDD power supply to the hub > > + 3V3 power supply to the hub > > + > > + vdd2-supply: > > + description: > > + 1V2 power supply to the hub > > How about v1p2-supply? The reason for vdd2 is this /* * Use generic names, as the actual names might differ between hubs. If a new * hub requires more than the currently supported supplies, add a new one here. */ static const char * const supply_names[] = { "vdd", "vdd2", }; from drivers/usb/misc/onboard_usb_hub.c. Francesco