On 01/11/2023 03:58, Tzuyi Chang wrote: > This patch adds the device tree bindings for the Realtek DHC RTD SoCs > GPIO controllers. > A nit, subject: drop second/last, redundant "bindings". The "dt-bindings" prefix is already stating that these are bindings. > Signed-off-by: Tzuyi Chang <tychang@xxxxxxxxxxx> > --- > .../bindings/gpio/realtek,rtd-gpio.yaml | 56 +++++++++++++++++++ > 1 file changed, 56 insertions(+) > create mode 100644 Documentation/devicetree/bindings/gpio/realtek,rtd-gpio.yaml How does your binding come after the user? > > diff --git a/Documentation/devicetree/bindings/gpio/realtek,rtd-gpio.yaml b/Documentation/devicetree/bindings/gpio/realtek,rtd-gpio.yaml > new file mode 100644 > index 000000000000..6cab7ec50c88 > --- /dev/null > +++ b/Documentation/devicetree/bindings/gpio/realtek,rtd-gpio.yaml > @@ -0,0 +1,56 @@ > +# SPDX-License-Identifier: (GPL-2.0 OR BSD-2-Clause) > +# Copyright 2023 Realtek Semiconductor Corporation > +%YAML 1.2 > +--- > +$id: http://devicetree.org/schemas/gpio/realtek,rtd-gpio.yaml# > +$schema: http://devicetree.org/meta-schemas/core.yaml# > + > +title: Realtek DHC GPIO controller What is DHC? Where is it explained in the binding? > + > +maintainers: > + - TY Chang <tychang@xxxxxxxxxxx> > + > +properties: > + compatible: > + enum: > + - realtek,rtd-gpio What is "rtd"? Generic name? Drop. You cannot have generic compatibles. > + - realtek,rtd1295-misc-gpio > + - realtek,rtd1295-iso-gpio > + - realtek,rtd1395-iso-gpio > + - realtek,rtd1619-iso-gpio > + > + reg: > + maxItems: 2 You need to describe the items instead. > + > + interrupts: > + maxItems: 2 You need to describe the items instead. > + > + gpio-ranges: true > + > + gpio-controller: true > + > + "#gpio-cells": > + const: 2 > + > +required: > + - compatible > + - reg > + - interrupts > + - gpio-ranges > + - gpio-controller > + - "#gpio-cells" Best regards, Krzysztof