On Fri, Oct 13, 2023 at 02:24:01PM +0200, Oleksij Rempel wrote: > diff --git a/drivers/net/dsa/microchip/ksz_common.c b/drivers/net/dsa/microchip/ksz_common.c > index db0ef4ad181e..bef1951fe6f2 100644 > --- a/drivers/net/dsa/microchip/ksz_common.c > +++ b/drivers/net/dsa/microchip/ksz_common.c > @@ -319,6 +319,8 @@ static const struct ksz_dev_ops ksz9477_dev_ops = { > .mdb_del = ksz9477_mdb_del, > .change_mtu = ksz9477_change_mtu, > .phylink_mac_link_up = ksz9477_phylink_mac_link_up, > + .wol_get = ksz9477_get_wol, > + .wol_set = ksz9477_set_wol, Can the dev_ops function pointers also be named get_wol() and set_wol() for consistency with everything else? > .config_cpu_port = ksz9477_config_cpu_port, > .tc_cbs_set_cinc = ksz9477_tc_cbs_set_cinc, > .enable_stp_addr = ksz9477_enable_stp_addr, > @@ -2935,6 +2937,28 @@ static int ksz_set_mac_eee(struct dsa_switch *ds, int port, > return 0; > }