On Thu, Jul 13, 2023 at 4:28 AM Conor Dooley <conor.dooley@xxxxxxxxxxxxx> wrote: > > On Thu, Jul 13, 2023 at 10:46:14AM +0200, Andrew Jones wrote: > > On Wed, Jul 12, 2023 at 10:43:33AM -0700, Evan Green wrote: > > > On Wed, Jul 12, 2023 at 3:39 AM Conor Dooley <conor.dooley@xxxxxxxxxxxxx> wrote: > > > > On Wed, Jul 12, 2023 at 10:41:17AM +0200, Samuel Ortiz wrote: > > > > > From: "Hongren (Zenithal) Zheng" <i@xxxxxxxxxxx> > > > > > > > > > > Parse Zb/Zk related string from DT and output them to cpuinfo. > > > > > > > > One thing that has sprung to mind is that this is not limited to DT > > > > anymore, since the information could in theory come from ACPI too. > > > > Ditto the title I guess. > > > > > > > > > It is worth noting that the Scalar Crypto extension defines "zk" as a > > > > > shorthand for the Zkn, Zkr and Zkt extensions. Since the Zkn one also > > > > > implies the Zbkb, Zbkc and Zbkx extensions, simply passing the valid > > > > > "zk" extension name through a DT will enable all of the Zbkb, Zbkc, > > > > > Zbkx, Zkn, Zkr and Zkt extensions. > > > > > > > > > > Also, since there currently is no mechanism to merge all enabled > > > > > extensions, the generated cpuinfo output could be relatively large. > > > > > For example, setting the "riscv,isa" DT property to "rv64imafdc_zk_zks" > > > > > will generate the following cpuinfo output: > > > > > "rv64imafdc_zbkb_zbkc_zbkx_zknd_zkne_zknh_zkr_zksed_zksh_zkt". > > > > > > > > On that note, I've created another version of what checking for > > > > supersets could look like, since it'll be needed either by my series or > > > > this one, depending on what gets merged first. I've yet to test the > > > > dedicated extensions part of it, but I wanted to get this out before I > > > > went looking at other fixes in the area. > > > > > > > > Evan, since it was you that commented on this stuff last time around, > > > > could you take another look? I'm still not keen on the "subset_of" > > > > arrays, but they're an improvement on what I had last time around for > > > > sure. > > > > > > > > > > This looks alright to me. At the risk of getting into bikeshedding > > > territory, the only awkward bit of it is it composes the extensions in > > > sort of the opposite way you'd expect. I tend to think of Zks as being > > > comprised of {zbkb, zbkc, zksed, zksh}, > > > > This is also the way I think of it, so, FWIW, I prefer the approach below, > > where bundles are expanded. > > I took the patch Evan sent me off-list & have spun it into a "real" > patch. I did some minor changes (c99 loop, __init marking) to match what > the code was already doing and expanded it to work for the new property > stuff. > I'm not sure that match_isa_ext() needs to be a function, given the > single user - it might be better refactored to drop the outer if & return > whether a match was found. > If done that would allow sharing the same function between isa string and > dedicated property parsing. I left it intact for now. Might also be > worth adding kerneldoc for that struct. > > -- >8 -- > From 8300b98e487e57d192bc9581c6a3639c40c52623 Mon Sep 17 00:00:00 2001 > From: Evan Green <evan@xxxxxxxxxxxx> > Date: Wed, 12 Jul 2023 10:36:15 -0700 > Subject: [PATCH] RISC-V: Add support Scalar Crypto using "bundled extensions" > > The Scalar Crypto specification defines Zk as a shorthand for the > Zkn, Zkr and Zkt extensions. The same follows for both Zkn, Zks and Zbk, > which are all shorthands for various other extensions. The detailed > breakdown can be found in their dt-binding entries. > > Since Zkn also implies the Zbkb, Zbkc and Zbkx extensions, simply passing > "zk" through a DT should enable all of Zbkb, Zbkc, Zbkx, Zkn, Zkr and Zkt. > For example, setting the "riscv,isa" DT property to "rv64imafdc_zk" > should generate the following cpuinfo output: > "rv64imafdc_zicntr_zicsr_zifencei_zihpm_zbkb_zbkc_zbkx_zknd_zkne_zknh_zkr_zkt" > > riscv_isa_ext_data grows a pair of new members, to permit setting the > relevant bits for "bundled" extensions, both while parsing the ISA string > and the new dedicated extension properties > > Co-developed-by: Conor Dooley <conor.dooley@xxxxxxxxxxxxx> > Signed-off-by: Conor Dooley <conor.dooley@xxxxxxxxxxxxx> > --- > There's basically none of the original patch left, so I have dropped the > co-developed-bys and signed-off-bys from before. It does need one from > you now though Evan! Oops, I hadn't realized this was blocked on me! Signed-off-by: Evan Green <evan@xxxxxxxxxxxx>