On Sat, Aug 19, 2023 at 11:02:45PM +0100, Andre Przywara wrote: > On Fri, 18 Aug 2023 22:21:03 -0500 > Chris Morgan <macroalpha82@xxxxxxxxx> wrote: > > > From: Chris Morgan <macromorgan@xxxxxxxxxxx> > > > > Add pinctrl nodes for pwm0 and pwm1. > > > > Signed-off-by: Chris Morgan <macromorgan@xxxxxxxxxxx> > > --- > > arch/arm/boot/dts/allwinner/sun8i-v3s.dtsi | 12 ++++++++++++ > > 1 file changed, 12 insertions(+) > > > > diff --git a/arch/arm/boot/dts/allwinner/sun8i-v3s.dtsi b/arch/arm/boot/dts/allwinner/sun8i-v3s.dtsi > > index 2b76a5b8ec19..3276b3b5de19 100644 > > --- a/arch/arm/boot/dts/allwinner/sun8i-v3s.dtsi > > +++ b/arch/arm/boot/dts/allwinner/sun8i-v3s.dtsi > > @@ -414,6 +414,18 @@ mmc1_pins: mmc1-pins { > > bias-pull-up; > > }; > > > > + /omit-if-no-ref/ > > + pwm0_pins: pwm0-pins { > > Since conceptually a certain PWM only drives one output pin, I see > other DTs using singular for the names here, so: > pwm0_pin: pwm0-pin { > > The pins and function names match the manual and the driver, so that's > correct. Okay, I'll change the name from "pwm*_pins" to "pwm*_pin". Thank you. > > Cheers, > Andre. > > > + pins = "PB4"; > > + function = "pwm0"; > > + }; > > + > > + /omit-if-no-ref/ > > + pwm1_pins: pwm1-pins { > > + pins = "PB5"; > > + function = "pwm1"; > > + }; > > + > > spi0_pins: spi0-pins { > > pins = "PC0", "PC1", "PC2", "PC3"; > > function = "spi0"; >