From: Rohan G Thomas <rohan.g.thomas@xxxxxxxxx> From: Rohan G Thomas <rohan.g.thomas@xxxxxxxxx> Date: Mon, Aug 14, 2023 at 15:06:37 > > > --- a/drivers/net/ethernet/stmicro/stmmac/stmmac.h > > +++ b/drivers/net/ethernet/stmicro/stmmac/stmmac.h > > @@ -219,6 +219,8 @@ struct stmmac_priv { > > int hwts_tx_en; > > bool tx_path_in_lpi_mode; > > bool tso; > > + bool tx_q_coe_lmt; > > Please use a flag here instead of "tx_q_coe_lmt". This is the preferrable > method now. > > Thanks, > Jose Thanks Jose for the feedback. If I read that correctly, your suggestion is to change " tx_q_coe_lmt" to something more readable, like "has_txcoe_limit". Please correct me if I understand it wrongly. BR, Rohan > > > + u32 tx_q_with_coe; > > int sph; > > int sph_cap; > > u32 sarc_type;