On Fri, Dec 5, 2014 at 6:02 AM, Benoit Parrot <bparrot@xxxxxx> wrote: > Add GPIO hogging documentation to gpio.txt > > Signed-off-by: Benoit Parrot <bparrot@xxxxxx> > --- > Changes since v2: > * Updated to the latest hog syntax. > > Changes since v1: > * Split the devicetree bindings documentation in its own patch. > > Documentation/devicetree/bindings/gpio/gpio.txt | 23 +++++++++++++++++++++++ > 1 file changed, 23 insertions(+) > > diff --git a/Documentation/devicetree/bindings/gpio/gpio.txt b/Documentation/devicetree/bindings/gpio/gpio.txt > index 3fb8f53..6d88133 100644 > --- a/Documentation/devicetree/bindings/gpio/gpio.txt > +++ b/Documentation/devicetree/bindings/gpio/gpio.txt > @@ -103,6 +103,22 @@ Every GPIO controller node must contain both an empty "gpio-controller" > property, and a #gpio-cells integer property, which indicates the number of > cells in a gpio-specifier. > > +The GPIO chip may contain GPIO hog definitions. GPIO hogging is a mechanism > +providing automatic GPIO request and configuration as part of the > +gpio-controller's driver probe function. > + > +Each GPIO hog definition is represented as a child node of the GPIO controller. > +Required properties: > +- gpio-hog: A property specifying that this child node represent a gpio-hog. > +- gpios: Store the gpio information (id, flags, ...). Shall contain the > + number of cells specified in its parent node (GPIO controller > + node). Since this property will only describe one GPIO, why use the plural form? Would it not be confusing? > +- direction: A property specifying the direction/value needed. This property > + can take the folowing values: input, output-high, output-low. nit: since this property not only describes the direction but also the (potential) value, I suggest to rename it to "state". -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html