Hi, Yinbo, On Fri, Jun 16, 2023 at 9:45 AM zhuyinbo <zhuyinbo@xxxxxxxxxxx> wrote: > > > Hi huacai, > > > 在 2023/6/15 下午7:15, zhuyinbo 写道: > > > > > > 在 2023/6/15 下午6:00, Huacai Chen 写道: > > > >>> +static void loongson2_pm_status_clear(void) > >>> +{ > >>> + u16 value; > >>> + > >>> + value = loongson2_pm_readw(LOONGSON2_PM1_STS_REG); > >>> + value |= (LOONGSON2_PM1_PWRBTN_STS | > >>> LOONGSON2_PM1_PCIEXP_WAKE_STS | > >>> + LOONGSON2_PM1_WAKE_STS); > >>> + loongson2_pm_writew(value, LOONGSON2_PM1_STS_REG); > >>> + loongson2_pm_writel(loongson2_pm_readl(LOONGSON2_GPE0_STS_REG), > >>> + LOONGSON2_GPE0_STS_REG); > >> Long-line warnings is removed in latest kernel, so you don't need to > >> split here. > > > > > > okay, I got it. > > > >> > >>> +} > >>> + > >>> +static void loongson2_power_button_irq_enable(void) > >> > >> Using loongson2_pm_irq_enable is a little better. > > > > > > Previously, you suggested that I combine loongson2_pm_irq_enable() and > power button irq enable code as loongson2_power_button_irq_enable, then > I remove the function loongson2_pm_irq_enable, in this case that I won't > be able to call loongson2_pm_irq_enable, so have I misunderstood your > meaning ? or only rename loongson2_power_button_irq_enable as > loongson2_pm_irq_enable ? I'm very sorry for that. At first I only wanted to combine two functions, but then I found the name loongson2_pm_irq_enable is better. So just rename is OK. Thanks. Huacai > > Thanks, > Yinbo > > > > > ... > > > >>> +static int loongson2_suspend_valid_state(suspend_state_t state) > >>> +{ > >>> + if (state == PM_SUSPEND_MEM) > >>> + return 1; > >>> + > >>> + return 0; > >> "return (state == PM_SUSPEND_MEM)" is enough. > > > > > > okay, I got it. > > > > > > Thanks, > > Yinbo > > > >