On Mon, Apr 24, 2023 at 08:40:07PM -0700, Bjorn Andersson wrote: > The data lanes of the QMP PHY is swapped in order to handle changing > orientation of the USB Type-C cable. Register a typec_switch device to > allow a TCPM to configure the orientation. > > The newly introduced orientation variable is adjusted based on the > request, and the initialized components are brought down and up again. > To keep track of what parts needs to be cycled new variables to keep > track of the individual init_count is introduced. > > Both the USB and the DisplayPort altmode signals are properly switched. > For DisplayPort the controller will after the TCPM having established > orientation power on the PHY, so this is not done implicitly, but for > USB the PHY typically is kept initialized across the switch, and must > therefor then be reinitialized. > > This is based on initial work by Wesley Cheng. > > Link: https://lore.kernel.org/r/20201009082843.28503-3-wcheng@xxxxxxxxxxxxxx/ > Signed-off-by: Bjorn Andersson <quic_bjorande@xxxxxxxxxxx> > --- > drivers/phy/qualcomm/phy-qcom-qmp-combo.c | 92 ++++++++++++++++++++--- > 1 file changed, 83 insertions(+), 9 deletions(-) > > diff --git a/drivers/phy/qualcomm/phy-qcom-qmp-combo.c b/drivers/phy/qualcomm/phy-qcom-qmp-combo.c > index 6748f31da7a3..5d6d6ef3944b 100644 > --- a/drivers/phy/qualcomm/phy-qcom-qmp-combo.c > +++ b/drivers/phy/qualcomm/phy-qcom-qmp-combo.c > @@ -2567,8 +2573,9 @@ static int qmp_combo_dp_exit(struct phy *phy) > > mutex_lock(&qmp->phy_mutex); > > - qmp_combo_com_exit(qmp); > + qmp_combo_com_exit(qmp, false); > > + qmp->dp_init_count--; Nit: add a newline for symmetry. > mutex_unlock(&qmp->phy_mutex); > > return 0; > @@ -3351,6 +3362,65 @@ static struct phy *qmp_combo_phy_xlate(struct device *dev, struct of_phandle_arg > return ERR_PTR(-EINVAL); > } > > +#if IS_ENABLED(CONFIG_TYPEC) > +static int qmp_combo_typec_switch_set(struct typec_switch_dev *sw, > + enum typec_orientation orientation) > +{ > + struct qmp_combo *qmp = typec_switch_get_drvdata(sw); > + const struct qmp_phy_cfg *cfg = qmp->cfg; > + > + if (orientation == qmp->orientation || orientation == TYPEC_ORIENTATION_NONE) > + return 0; > + > + mutex_lock(&qmp->phy_mutex); > + qmp->orientation = orientation; > + > + if (qmp->init_count) { > + if (qmp->usb_init_count) > + qmp_combo_usb_power_off(qmp->usb_phy); > + qmp_combo_com_exit(qmp, true); > + > + qmp_combo_com_init(qmp, true); > + if (qmp->usb_init_count) > + qmp_combo_usb_power_on(qmp->usb_phy); > + if (qmp->dp_init_count) > + cfg->dp_aux_init(qmp); > + } > + mutex_unlock(&qmp->phy_mutex); > + > + return 0; > +} > + > +static void qmp_combo_typec_unregister(void *data) > +{ > + struct qmp_combo *qmp = data; > + > + typec_switch_unregister(qmp->sw); > +} > + > +static int qmp_combo_typec_switch_register(struct qmp_combo *qmp) > +{ > + struct typec_switch_desc sw_desc = {}; > + struct device *dev = qmp->dev; > + > + sw_desc.drvdata = qmp; > + sw_desc.fwnode = dev->fwnode; > + sw_desc.set = qmp_combo_typec_switch_set; Nit: I'd add a newline here for readability. > + qmp->sw = typec_switch_register(dev, &sw_desc); > + if (IS_ERR(qmp->sw)) { > + dev_err(dev, "Unable to register typec switch: %pe\n", qmp->sw); > + return PTR_ERR(qmp->sw); > + } > + > + return devm_add_action_or_reset(dev, qmp_combo_typec_unregister, qmp); > +} > +#else > +static int qmp_combo_typec_switch_register(struct qmp_combo *qmp) > +{ > + return 0; > +} > +#endif Perhaps you can move the type-c block after qmp_combo_register_clocks() above to keep the type-c and later added bridge functions together and better reflect the probe init order (e.g. keeping the dt-functions just above probe()). > + > static int qmp_combo_probe(struct platform_device *pdev) > { > struct qmp_combo *qmp; > @@ -3385,6 +3455,10 @@ static int qmp_combo_probe(struct platform_device *pdev) > if (ret) > return ret; > > + ret = qmp_combo_typec_switch_register(qmp); > + if (ret) > + return ret; > + > /* Check for legacy binding with child nodes. */ > usb_np = of_get_child_by_name(dev->of_node, "usb3-phy"); > if (usb_np) { Looks good otherwise: Reviewed-by: Johan Hovold <johan+linaro@xxxxxxxxxx> Johan