On Thu, Mar 16, 2023 at 11:52:34AM -0700, Jakub Kicinski wrote: > On Thu, 16 Mar 2023 13:36:09 -0500 Andrew Halaney wrote: > > static void emac3_config_cbs(struct mac_device_info *hw, u32 send_slope, > > u32 idle_slope, u32 high_credit, > > u32 low_credit, u32 queue) > > > > I agree, that's quite gnarly to read. the emac3_config_cbs is the > > callback, so it's already at 6 arguments, so there's nothing I can > > trim there. I could create some struct for readability, populate that, > > then call the do_config_cbs() func with it from emac3_config_cbs. > > Is that the sort of thing you want to see? > > Yes, a structure is much better, because it can be initialized member > by member, > > struct bla my_bla = { .this = 1, .that = 2, .and = 3, another = 4, }; > > That's much easier to read. A poor man's version of Python's keyword > arguments, if you will. What I would say is be careful with that - make sure "struct bla" is specific to the interface being called and not generic. I had that mistake with struct phylink_state... and there is an endless stream of people who don't seem to bother reading the documentation, who blindly access whatever members of that they damn well please because it suits them, even when either they shouldn't be writing to them, or when phylink doesn't guarantee their contents, they read them. As a result, I'm now of the opinion that using a struct to pass arguments is in principle a bad idea. There's other reasons why it's a bad idea. Many ABIs are capable of passing arguments to functions via processor registers. As soon as one uses a struct, they typically end up being written to memory. Not only does that potentially cause cache line churn, it also means that there could be more slow memory accesses that have to be made at some point, potentially making other accesses slow. So, all in all, I'm really not a fan of the struct approach for all the reasons above. -- RMK's Patch system: https://www.armlinux.org.uk/developer/patches/ FTTP is here! 40Mbps down 10Mbps up. Decent connectivity at last!