Re: [PATCH v3 0/3] iio: Add Cosmic Circuits ADC support

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




Ezequiel,

On Thu, Nov 13, 2014 at 6:14 AM, Ezequiel Garcia
<ezequiel.garcia@xxxxxxxxxx> wrote:
> Here goes the third round of this series. You can find the previous patchset
> and its discussion here: http://thread.gmane.org/gmane.linux.kernel.iio/14553.
>
> Changes from v2:
>
>   * Changed a devicetree property from adc-available-channels to
>     adc-reserved-channels, so it can be made optional.
>
>   * Renamed the driver from cc_10001_xxx to cc10001_xxx so it's consistent
>     with the rest of the kernel style.
>
>   * Some more minor cosmetic fixes.
>
> Changes from v1:
>
>   * Removed unneeded header includes.
>
>   * Changed all the names and macros prefix: s/CC_10001_/CC10001_.
>
>   * Used .update_scan_mode callback to preallocate the buffer.
>
>   * Used indio_dev for the struct iio_dev.
>
>   * Only read the regulator voltage when needed.
>
>   * Fixed probe() error handling.
>
>   * Used for_each_set_bit() instead of open-coding it.
>
>   * Name the power-down register as _POWER_UP, to make the code
>     less silly.
>
>   * Error out when no valid sample can be read (i.e. when end-of-conversion
>     poll times out).
>
>   * ... plus some assorted code cleaning based on the feedback.
>
> Ezequiel Garcia (1):
>   DT: Add a vendor prefix for Cosmic Circuits
>
> Phani Movva (2):
>   iio: adc: Cosmic Circuits 10001 ADC driver
>   DT: iio: adc: Add CC_10001 binding documentation

This series (with v4 of patch 2/3):

Reviewed-by: Andrew Bresticker <abrestic@xxxxxxxxxxxx>
--
To unsubscribe from this list: send the line "unsubscribe devicetree" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Device Tree Compilter]     [Device Tree Spec]     [Linux Driver Backports]     [Video for Linux]     [Linux USB Devel]     [Linux PCI Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Yosemite Backpacking]
  Powered by Linux