Hi Rob, Thanks for the review. On Wed, Feb 8, 2023 at 4:52 AM Rob Herring <robh@xxxxxxxxxx> wrote: > > On Sat, Feb 04, 2023 at 09:30:38PM +0800, Pin-yen Lin wrote: > > ITE IT6505 can be used in systems to switch the DP traffic between > > two downstreams, which can be USB Type-C DisplayPort alternate mode > > lane or regular DisplayPort output ports. > > > > Update the binding to accommodate this usage by introducing a > > data-lanes and a mode-switch property on endpoints. > > > > Signed-off-by: Pin-yen Lin <treapking@xxxxxxxxxxxx> > > > > --- > > > > Changes in v11: > > - Updated the description of the endpoints in the bindings > > - Referenced video-interfaces.yaml instead for the endpoints binding > > - Removed duplicated definitions from inherited schema > > > > Changes in v9: > > - Fixed subject prefix again > > - Changed the naming of the example node for it6505 > > > > Changes in v8: > > - Updated bindings for data-lanes property > > - Fixed subject prefix > > > > Changes in v7: > > - Fixed issues reported by dt_binding_check. > > - Updated the schema and the example dts for data-lanes. > > - Changed to generic naming for the example dts node. > > > > Changes in v6: > > - Remove switches node and use endpoints and data-lanes property to > > describe the connections. > > > > .../bindings/display/bridge/ite,it6505.yaml | 101 +++++++++++++++--- > > 1 file changed, 88 insertions(+), 13 deletions(-) > > > > diff --git a/Documentation/devicetree/bindings/display/bridge/ite,it6505.yaml b/Documentation/devicetree/bindings/display/bridge/ite,it6505.yaml > > index b16a9d9127dd..8ae9c5cba22c 100644 > > --- a/Documentation/devicetree/bindings/display/bridge/ite,it6505.yaml > > +++ b/Documentation/devicetree/bindings/display/bridge/ite,it6505.yaml > > @@ -75,22 +75,49 @@ properties: > > port@1: > > $ref: /schemas/graph.yaml#/$defs/port-base > > unevaluatedProperties: false > > - description: Video port for DP output > > + description: > > + Video port for DP output. Each endpoint connects to a video output > > + downstream, and the "data-lanes" property is used to describe the pin > > + connections. 0, 1, 2, 3 in "data-lanes" maps to TX0, TX1, TX2, TX3, > > + respectively. > > > > - properties: > > - endpoint: > > - $ref: /schemas/graph.yaml#/$defs/endpoint-base > > + > > + patternProperties: > > + "^endpoint@[01]$": > > + $ref: /schemas/media/video-interfaces.yaml# > > unevaluatedProperties: false > > > > properties: > > + reg: true > > + > > + remote-endpoint: true > > + > > data-lanes: > > - minItems: 1 > > - uniqueItems: true > > - items: > > - - enum: [ 0, 1 ] > > - - const: 1 > > - - const: 2 > > - - const: 3 > > + oneOf: > > + - items: > > + - enum: [0, 1, 2, 3] > > + > > + - items: > > + - const: 0 > > + - const: 1 > > + > > + - items: > > + - const: 2 > > + - const: 3 > > + > > + - items: > > + - const: 0 > > + - const: 1 > > + - const: 2 > > + - const: 3 > > + > > + mode-switch: > > + type: boolean > > + description: Register this node as a Type-C mode switch or not. > > Existing users put this property in the device's node, not the endpoint. > That seems more like a property of the device, than the DP link. In our use case, we want to register two mode switches for the same device. That's why we put the "mode-switch" property in the endpoints instead of the device node. > > You are using fwnode_typec_mux_get(), right? Yes. This is called by cros_ec_typec.c[1] in our use case. [1]: https://elixir.bootlin.com/linux/latest/source/drivers/platform/chrome/cros_ec_typec.c#L148 Regards, Pin-yen > > Rob