Thanks a lot, Adrian and andy! Appreciate it On Wed, 7 Dec 2022 at 18:49, Andy Shevchenko <andy.shevchenko@xxxxxxxxx> wrote: > > On Wed, Dec 7, 2022 at 3:49 PM Adrian Hunter <adrian.hunter@xxxxxxxxx> wrote: > > On 7/12/22 15:25, Andy Shevchenko wrote: > > > On Wed, Dec 7, 2022 at 3:01 PM Tomer Maimon <tmaimon77@xxxxxxxxx> wrote: > > >> On Mon, 5 Dec 2022 at 16:33, Adrian Hunter <adrian.hunter@xxxxxxxxx> wrote: > > >>> On 5/12/22 16:17, Andy Shevchenko wrote: > > >>>> On Mon, Dec 5, 2022 at 4:14 PM Andy Shevchenko > > >>>> <andy.shevchenko@xxxxxxxxx> wrote: > > >>>>> On Mon, Dec 5, 2022 at 3:41 PM Adrian Hunter <adrian.hunter@xxxxxxxxx> wrote: > > >>>>>> On 5/12/22 15:25, Andy Shevchenko wrote: > > >>>>>>> On Mon, Dec 5, 2022 at 1:20 PM Tomer Maimon <tmaimon77@xxxxxxxxx> wrote: > > ... > > > >>>>>>> devm_ is problematic in your case. > > >>>>>>> TL;DR: you need to use clk_get_optional() and clk_put(). > > >>>>>> > > >>>>>> devm_ calls exactly those, so what is the issue? > > >>>>> > > >>>>> The issue is the error path or removal stage where it may or may be > > >>>>> not problematic. To be on the safe side, the best approach is to make > > >>>>> sure that allocated resources are being deallocated in the reversed > > >>>>> order. That said, the > > >>>>> > > >>>>> 1. call non-devm_func() > > >>>>> 2. call devm_func() > > >>>>> > > >>>>> is wrong strictly speaking. > > >>>> > > >>>> To elaborate more, the > > >>>> > > >>>> 1. call all devm_func() > > >>>> 2. call only non-devm_func() > > >>>> > > >>>> is the correct order. > > >>> > > >>> 1. WRT pltfm_host->clk, that is what is happening > > >>> 2. WRT other resources that is simply not always possible because not every resource is wrapped by devm_ > > >>> e.g. mmc_alloc_host() / mmc_free_host() > > >> I little confused about what to decide, should I use only > > >> non-devm_func because mmc_alloc_host() / mmc_free_host() is not > > >> warrped with devm_? > > > > > > It is up to you how to proceed. I pointed out the problem with your > > > code which may or may not be fatal. > > > > > > If you want to solve it, there are several approaches: > > > 1) get rid of devm_ completely; > > > 2) properly shuffle the ordering in ->probe(), so all devm_ calls are > > > followed by non-devm_; > > > 3) wrap non-devm_ cals to become managed (see > > > devm_add_action_or_reset() approach); > > > 4) fix SDHCI / MMC layer by providing necessary devm_ calls and/or fix > > > sdhci_pltfm_register() to handle the clock. > > > > I can take care of sdhci_pltfm when I next have some time. > > Otherwise it looks OK to me, so I am acking it. > > Thank you! > > > > Personally, the list order is from the least, what I prefer, to the > > > most (i.o.w. I would like to see rather 4) than 1) to be implemented). > > > > > >>>> Hence in this case the driver can be worked around easily (by > > >>>> shuffling the order in ->probe() to call devm_ first), but as I said > > >>>> looking into implementation of the _unregister() I'm pretty sure that > > >>>> clock management should be in sdhci-pltfm, rather than in all callers > > >>>> who won't need the full customization. > > >>>> > > >>>> Hope this helps to understand my point. > > >>>> > > >>>>>>> Your ->remove() callback doesn't free resources in the reversed order > > >>>>>>> which may or, by luck, may not be the case of all possible crashes, > > >>>>>>> UAFs, races, etc during removal stage. All the same for error path in > > >>>>>>> ->probe(). > > >>>>> > > >>>>> I also pointed out above what would be the outcome of neglecting this rule. > > ... > > > >>>>>>>>> Why can't you use sdhci_pltfm_register()? > > >>>>>>>> two things are missing in sdhci_pltfm_register > > >>>>>>>> 1. clock. > > >>>>>>> > > >>>>>>> Taking into account the implementation of the corresponding > > >>>>>>> _unregister() I would add the clock handling to the _register() one. > > >>>>>>> Perhaps via a new member of the platform data that supplies the name > > >>>>>>> and index of the clock and hence all clk_get_optional() / clk_put will > > >>>>>>> be moved there. > > >> Do you mean to add it to sdhci_pltfm_register function? if yes I > > >> believe it will take some time to modify sdhci_pltfm_register > > >> I prefer not to use sdhci_pltfm_register. > > > > > > In the Linux kernel we are trying hard to avoid code duplication. Why > > > do you need it to be open coded? (Yes, I heard you, but somebody > > > should fix the issues with that funcion at some point, right?) > > > > > >>>>>>>> 2. Adding SDHCI_CAN_DO_8BIT capability according the eMMC capabilities. > > >>>>>>> > > >>>>>>> All the same, why can't platform data be utilised for this? > > -- > With Best Regards, > Andy Shevchenko