On 14/11/2022 15:54, Johan Hovold wrote:
On Sat, Nov 12, 2022 at 02:31:27PM +0300, Dmitry Baryshkov wrote:
On 11/11/2022 12:24, Johan Hovold wrote:
The common registers are shared by the USB and DP parts of the PHY so
drop the misleading "dp" prefix from the corresponding pointers.
Note that the "DP" prefix could also be dropped from the corresponding
defines, but leave that in place for now.
Signed-off-by: Johan Hovold <johan+linaro@xxxxxxxxxx>
---
drivers/phy/qualcomm/phy-qcom-qmp-combo.c | 24 +++++++++++------------
1 file changed, 12 insertions(+), 12 deletions(-)
Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@xxxxxxxxxx>
Note regarding the last phrase: I'd suggest leaving the DP prefix in
register names, it makes it easier to visually note & verify the
register block.
My point is that "DP" was never part of the COM register block name. The
confusion likely comes from the vendor driver naming these defines along
the lines of
USB3_DP_COM_POWER_DOWN_CTRL
Here "USB3_DP" is the common prefix for all defines that apply to both
"parts" of the PHY so the corresponding Linux define
QPHY_V3_DP_COM_POWER_DOWN_CTRL
should either include "USB3" or drop "DP".
My thought was that we already have too many _COM_ defines in the qmp
headers. Having QPHY_Vn_COM_something would make it too easy to mix it
with QSERDES_Vn_COM_foo. Thus I'd vote to leave DP_COM prefix in place.
While it might be not fully accurate, it serves the point of identifying
the register block.
This becomes more apparent on SC8280XP where the corresponding define
is:
USB43DP_COM_POWER_DOWN_CTRL
I'd still use something like QPHY_V10_DP_COM_POWER_DOWN_CTRL here.
Johan
--
With best wishes
Dmitry