On 12/11/2022 15:10, Aurelien Jarno wrote: > Add the RNG bindings for the RK3568 SoC from Rockchip > > Signed-off-by: Aurelien Jarno <aurelien@xxxxxxxxxxx> > --- > .../devicetree/bindings/rng/rockchip-rng.yaml | 62 +++++++++++++++++++ > 1 file changed, 62 insertions(+) > create mode 100644 Documentation/devicetree/bindings/rng/rockchip-rng.yaml > > diff --git a/Documentation/devicetree/bindings/rng/rockchip-rng.yaml b/Documentation/devicetree/bindings/rng/rockchip-rng.yaml > new file mode 100644 > index 000000000000..87d80e8ff7f2 > --- /dev/null > +++ b/Documentation/devicetree/bindings/rng/rockchip-rng.yaml Filename matching compatible, so "rockchip,rk3568-rng.yaml" > @@ -0,0 +1,62 @@ > +# SPDX-License-Identifier: (GPL-2.0-only OR BSD-2-Clause) > +%YAML 1.2 > +--- > +$id: http://devicetree.org/schemas/rng/rockchip,rk-rng.yaml# > +$schema: http://devicetree.org/meta-schemas/core.yaml# > + > +title: Rockchip TRNG bindings Drop "bindings" > + > +description: > + This driver interface with the True Random Number Generator present in some Drop "This driver interface" and make it a proper sentence. Bindings are not about drivers. > + Rockchip SoCs. > + > +maintainers: > + - Aurelien Jarno <aurelien@xxxxxxxxxxx> > + > +properties: > + compatible: > + oneOf: It's not a oneOf. Drop. > + - const: rockchip,rk3568-rng > + > + reg: > + maxItems: 1 > + > + clocks: > + minItems: 2 Drop minItems. > + maxItems: 2 > + > + clock-names: > + items: > + - const: clk > + - const: hclk You need to explain what are these in clocks. Also you need better names. A clock name "clk" is useless. > + > + resets: > + maxItems: 1 > + > + reset-names: > + items: > + - const: reset Drop reset-names entirely, not useful. > + > +required: > + - compatible > + - reg > + - clocks > + - clock-names > + - resets > + - reset-names Best regards, Krzysztof