On 26.09.2022 09:43, Krzysztof Kozlowski wrote: > When BLSPI1 (originally SPI0, later renamed in commit f82c48d46852 > ("arm64: dts: qcom: ipq6018: correct QUP peripheral labels")) was added, > the device node lacked respective pin configuration assignment. It > used also blsp0_spi function but that was probably the same mistake as > naming it SPI0. > > Fixes: 5bf635621245 ("arm64: dts: ipq6018: Add a few device nodes") > Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski@xxxxxxxxxx> > --- Reviewed-by: Konrad Dybcio <konrad.dybcio@xxxxxxxxxxxxxx> Konrad > arch/arm64/boot/dts/qcom/ipq6018-cp01-c1.dts | 4 +++- > 1 file changed, 3 insertions(+), 1 deletion(-) > > diff --git a/arch/arm64/boot/dts/qcom/ipq6018-cp01-c1.dts b/arch/arm64/boot/dts/qcom/ipq6018-cp01-c1.dts > index 1ba2eca33c7b..afc2dc79767d 100644 > --- a/arch/arm64/boot/dts/qcom/ipq6018-cp01-c1.dts > +++ b/arch/arm64/boot/dts/qcom/ipq6018-cp01-c1.dts > @@ -37,6 +37,8 @@ &blsp1_i2c3 { > > &blsp1_spi1 { > cs-select = <0>; > + pinctrl-0 = <&spi_0_pins>; > + pinctrl-names = "default"; > status = "okay"; > > flash@0 { > @@ -57,7 +59,7 @@ i2c_1_pins: i2c-1-pins { > > spi_0_pins: spi-0-pins { > pins = "gpio38", "gpio39", "gpio40", "gpio41"; > - function = "blsp0_spi"; > + function = "blsp1_spi"; > drive-strength = <8>; > bias-pull-down; > };