On 5.07.2022 15:39, Christian Marangi wrote: > Add missing definition for mdio0 pins used for gpio-bitbang driver,i2c4 > pins and rgmii2 pins for ipq8064. > > Signed-off-by: Christian Marangi <ansuelsmth@xxxxxxxxx> > Tested-by: Jonathan McDowell <noodles@xxxxxxxx> > --- > arch/arm/boot/dts/qcom-ipq8064.dtsi | 34 +++++++++++++++++++++++++++++ > 1 file changed, 34 insertions(+) > > diff --git a/arch/arm/boot/dts/qcom-ipq8064.dtsi b/arch/arm/boot/dts/qcom-ipq8064.dtsi > index 4b475d98343c..f06a17bd915a 100644 > --- a/arch/arm/boot/dts/qcom-ipq8064.dtsi > +++ b/arch/arm/boot/dts/qcom-ipq8064.dtsi > @@ -382,6 +382,15 @@ mux { > }; > }; > Hi, > + i2c4_pins: i2c4_pinmux { No underscores in node names (use them only in labels), please. Also, please rename this to something like i2c4-default, for example to make it clear which power state it represents (I suppose i2c4-sleep is going to appear sometime in the as well). > + mux { Please drop the unnecessary mux{} level. Konrad > + pins = "gpio12", "gpio13"; > + function = "gsbi4"; > + drive-strength = <12>; > + bias-disable; > + }; > + }; > + > spi_pins: spi_pins { > mux { > pins = "gpio18", "gpio19", "gpio21"; > @@ -424,6 +433,8 @@ mux { > > pullups { > pins = "gpio39"; > + function = "nand"; > + drive-strength = <10>; > bias-pull-up; > }; > > @@ -431,9 +442,32 @@ hold { > pins = "gpio40", "gpio41", "gpio42", > "gpio43", "gpio44", "gpio45", > "gpio46", "gpio47"; > + function = "nand"; > + drive-strength = <10>; > bias-bus-hold; > }; > }; > + > + mdio0_pins: mdio0_pins { > + mux { > + pins = "gpio0", "gpio1"; > + function = "mdio"; > + drive-strength = <8>; > + bias-disable; > + }; > + }; > + > + rgmii2_pins: rgmii2_pins { > + mux { > + pins = "gpio27", "gpio28", "gpio29", > + "gpio30", "gpio31", "gpio32", > + "gpio51", "gpio52", "gpio59", > + "gpio60", "gpio61", "gpio62"; > + function = "rgmii2"; > + drive-strength = <8>; > + bias-disable; > + }; > + }; > }; > > intc: interrupt-controller@2000000 {