The dpi/dpintf driver and the added helper functions are required for the DisplayPort driver to work. This series is separated from [1] which is original from Guillaume. The display port driver is [2]. Changes for v15: 1. Add a patch to remove support for output yuv422 for previous socs. 2. Only remain output format of reg888/yuv422 support for mt8195. 3. Adjust the order of patches. Changes for v14: 1. Separate a new binding patch to modify mediatek string format. 2. Use GENMASK(4, 0) for INT_MATRIX_SEL_MASK in patch "Add YUV422 output support" 3. Change kernel doc description of support_direct_pin. 4. Change to use pixels_per_iter to control quantity of transferred pixels per iterration. Changes for v13: 1. Change mediatek,mt8195-dp_intf to mediatek,mt8195-dp-intf. 2. Add kernel doc for mtk_dpi_conf. 3. Drop patch of tvd_pll enable. 4. Squash some color format transfer related patches. 5. Add new patch to support setting of direct connection to pins. 6. Change fix tag of "drm/mediatek: dpi: Only enable dpi after the bridge is enabled". Changes for v12: 1. Remove pll_gate. 2. Add more detailed commit message. 3. Separate tvd_clk patch and yuv422 output support from add dpintf support patch 4. Remove limit patch and use common driver codes to determine this. Changes for v11: 1. Rename ck_cg to pll_gate. 2. Add some commit message to clarify the modification reason. 3. Fix some driver order and modify for reviewers' comments. [1]:https://lore.kernel.org/all/20220523104758.29531-1-granquet@xxxxxxxxxxxx/ [2]:https://lore.kernel.org/all/20220610105522.13449-1-rex-bc.chen@xxxxxxxxxxxx/ Bo-Chen Chen (6): dt-bindings: mediatek,dpi: Revise mediatek strings to correct format drm/mediatek: dpi: Add kernel document for struct mtk_dpi_conf drm/mediatek: dpi: Remove output format of YUV drm/mediatek: dpi: Add support for quantization range drm/mediatek: dpi: Add YUV422 output support drm/mediatek: dpi: add config to support direct connection to dpi panels Guillaume Ranquet (9): drm/mediatek: dpi: implement a CK/DE pol toggle in SoC config drm/mediatek: dpi: implement a swap_input toggle in SoC config drm/mediatek: dpi: move dimension mask to SoC config drm/mediatek: dpi: move hvsize_mask to SoC config drm/mediatek: dpi: move swap_shift to SoC config drm/mediatek: dpi: move the yuv422_en_bit to SoC config drm/mediatek: dpi: move the csc_enable bit to SoC config drm/mediatek: dpi: Only enable dpi after the bridge is enabled drm/mediatek: dpi: Add dp_intf support Markus Schneider-Pargmann (1): dt-bindings: mediatek,dpi: Add DP_INTF compatible .../display/mediatek/mediatek,dpi.yaml | 11 +- drivers/gpu/drm/mediatek/mtk_dpi.c | 283 ++++++++++++++---- drivers/gpu/drm/mediatek/mtk_dpi_regs.h | 18 ++ drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.c | 4 + drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.h | 1 + drivers/gpu/drm/mediatek/mtk_drm_drv.c | 3 + 6 files changed, 257 insertions(+), 63 deletions(-) -- 2.18.0