czw., 9 cze 2022 o 13:56 Krzysztof Kozlowski <krzysztof.kozlowski@xxxxxxxxxx> napisał(a): > > The node names should be generic and DT schema expects certain pattern > (e.g. with key/button/switch). > > Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski@xxxxxxxxxx> > --- > arch/arm64/boot/dts/rockchip/rk3308-evb.dts | 2 +- > .../boot/dts/rockchip/rk3326-odroid-go2.dts | 32 +++++++++---------- > .../boot/dts/rockchip/rk3328-nanopi-r2s.dts | 2 +- > arch/arm64/boot/dts/rockchip/rk3368-evb.dtsi | 2 +- > .../boot/dts/rockchip/rk3368-geekbox.dts | 2 +- > .../dts/rockchip/rk3368-orion-r68-meta.dts | 2 +- > .../boot/dts/rockchip/rk3368-px5-evb.dts | 2 +- > arch/arm64/boot/dts/rockchip/rk3368-r88.dts | 2 +- > .../boot/dts/rockchip/rk3399-firefly.dts | 2 +- > .../dts/rockchip/rk3399-gru-chromebook.dtsi | 2 +- > .../boot/dts/rockchip/rk3399-gru-kevin.dts | 2 +- > .../boot/dts/rockchip/rk3399-gru-scarlet.dtsi | 2 +- > .../boot/dts/rockchip/rk3399-khadas-edge.dtsi | 2 +- > .../boot/dts/rockchip/rk3399-nanopi-r4s.dts | 4 +-- > .../boot/dts/rockchip/rk3399-nanopi4.dtsi | 2 +- > .../boot/dts/rockchip/rk3399-orangepi.dts | 2 +- > .../boot/dts/rockchip/rk3399-pinebook-pro.dts | 4 +-- > .../boot/dts/rockchip/rk3399-roc-pc.dtsi | 2 +- > .../boot/dts/rockchip/rk3399-rockpro64.dtsi | 2 +- > .../boot/dts/rockchip/rk3399-sapphire.dtsi | 2 +- > .../boot/dts/rockchip/rk3566-pinenote.dtsi | 2 +- > 21 files changed, 38 insertions(+), 38 deletions(-) > > diff --git a/arch/arm64/boot/dts/rockchip/rk3308-evb.dts b/arch/arm64/boot/dts/rockchip/rk3308-evb.dts > index 9b4f855ea5d4..4b5413b12bfa 100644 > --- a/arch/arm64/boot/dts/rockchip/rk3308-evb.dts > +++ b/arch/arm64/boot/dts/rockchip/rk3308-evb.dts > @@ -75,7 +75,7 @@ gpio-keys { > pinctrl-names = "default"; > pinctrl-0 = <&pwr_key>; > > - power { > + power-key { > gpios = <&gpio0 RK_PA6 GPIO_ACTIVE_LOW>; > linux,code = <KEY_POWER>; > label = "GPIO Key Power"; > diff --git a/arch/arm64/boot/dts/rockchip/rk3326-odroid-go2.dts b/arch/arm64/boot/dts/rockchip/rk3326-odroid-go2.dts > index ea0695b51ecd..72328dd993ee 100644 > --- a/arch/arm64/boot/dts/rockchip/rk3326-odroid-go2.dts > +++ b/arch/arm64/boot/dts/rockchip/rk3326-odroid-go2.dts > @@ -71,82 +71,82 @@ gpio-keys { > * |------------------------------------------------| > */ > > - sw1 { > + switch-1 { Wouldn't it make more sense to rename this and all other renamed nodes in this dts into "button-dpad-up" or "button-1", as on the physical device those are buttons and the naming scheme of "sw" + number seems to be a carryover from downstream sources. > gpios = <&gpio1 RK_PB4 GPIO_ACTIVE_LOW>; > label = "DPAD-UP"; > linux,code = <BTN_DPAD_UP>; > }; > - sw2 { > + switch-2 { > gpios = <&gpio1 RK_PB5 GPIO_ACTIVE_LOW>; > label = "DPAD-DOWN"; > linux,code = <BTN_DPAD_DOWN>; > }; > - sw3 { > + switch-3 { > gpios = <&gpio1 RK_PB6 GPIO_ACTIVE_LOW>; > label = "DPAD-LEFT"; > linux,code = <BTN_DPAD_LEFT>; > }; > - sw4 { > + switch-4 { > gpios = <&gpio1 RK_PB7 GPIO_ACTIVE_LOW>; > label = "DPAD-RIGHT"; > linux,code = <BTN_DPAD_RIGHT>; > }; > - sw5 { > + switch-5 { > gpios = <&gpio1 RK_PA2 GPIO_ACTIVE_LOW>; > label = "BTN-A"; > linux,code = <BTN_EAST>; > }; > - sw6 { > + switch-6 { > gpios = <&gpio1 RK_PA5 GPIO_ACTIVE_LOW>; > label = "BTN-B"; > linux,code = <BTN_SOUTH>; > }; > - sw7 { > + switch-7 { > gpios = <&gpio1 RK_PA6 GPIO_ACTIVE_LOW>; > label = "BTN-Y"; > linux,code = <BTN_WEST>; > }; > - sw8 { > + switch-8 { > gpios = <&gpio1 RK_PA7 GPIO_ACTIVE_LOW>; > label = "BTN-X"; > linux,code = <BTN_NORTH>; > }; > - sw9 { > + switch-9 { > gpios = <&gpio2 RK_PA0 GPIO_ACTIVE_LOW>; > label = "F1"; > linux,code = <BTN_TRIGGER_HAPPY1>; > }; > - sw10 { > + switch-10 { > gpios = <&gpio2 RK_PA1 GPIO_ACTIVE_LOW>; > label = "F2"; > linux,code = <BTN_TRIGGER_HAPPY2>; > }; > - sw11 { > + switch-11 { > gpios = <&gpio2 RK_PA2 GPIO_ACTIVE_LOW>; > label = "F3"; > linux,code = <BTN_TRIGGER_HAPPY3>; > }; > - sw12 { > + switch-12 { > gpios = <&gpio2 RK_PA3 GPIO_ACTIVE_LOW>; > label = "F4"; > linux,code = <BTN_TRIGGER_HAPPY4>; > }; > - sw13 { > + switch-13 { > gpios = <&gpio2 RK_PA4 GPIO_ACTIVE_LOW>; > label = "F5"; > linux,code = <BTN_TRIGGER_HAPPY5>; > }; > - sw14 { > + switch-14 { > gpios = <&gpio2 RK_PA5 GPIO_ACTIVE_LOW>; > label = "F6"; > linux,code = <BTN_TRIGGER_HAPPY6>; > }; > - sw15 { > + switch-15 { > gpios = <&gpio2 RK_PA6 GPIO_ACTIVE_LOW>; > label = "TOP-LEFT"; > linux,code = <BTN_TL>; > }; > - sw16 { > + switch-16 { > gpios = <&gpio2 RK_PA7 GPIO_ACTIVE_LOW>; > label = "TOP-RIGHT"; > linux,code = <BTN_TR>; > diff --git a/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts b/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts > index 3857d487ab84..1445b879ac7a 100644 > --- a/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts > +++ b/arch/arm64/boot/dts/rockchip/rk3328-nanopi-r2s.dts > @@ -34,7 +34,7 @@ keys { > pinctrl-0 = <&reset_button_pin>; > pinctrl-names = "default"; > > - reset { > + key-reset { > label = "reset"; > gpios = <&gpio0 RK_PA0 GPIO_ACTIVE_LOW>; > linux,code = <KEY_RESTART>; [snip]