On 08/03/2022 20:08, Brian Norris wrote: > I want to add, deprecate, and bugfix some properties, as well as add the > first users. This is easier with a proper schema. > > The transformation is mostly straightforward, plus a few notable tweaks: > > * Renamed rockchip,dram_speed_bin to rockchip,ddr3_speed_bin. The > driver code and the example matched, but the description was > different. I went with the implementation. Note that this property is > also slated for deprecation/deletion in the subsequent patches. > > * Drop upthreshold and downdifferential properties from the example. > These were undocumented (so, wouldn't pass validation), but were > representing software properties (governor tweaks). I drop them from > the driver in subsequent patches. > > * Rename clock from pclk_ddr_mon to dmc_clk. The driver, DT example, > and all downstream users matched -- the binding definition was the > exception. Anyway, "dmc_clk" is a more appropriately generic name. > > * Choose a better filename and location (this is a memory controller). > > Signed-off-by: Brian Norris <briannorris@xxxxxxxxxxxx> > --- > > Changes in v4: > * Update .yaml to use more "default" entries, instead of free-form text > * s/phandle-array/phandle/ > * Move to .../memory-controllers, update filename > > Changes in v3: > * Add |maxItems| for devfreq-events > * Improve deprecation notes > > Changes in v2: > * rename to 'memory-controller' in example > * place 'required' after properties > * drop superluous free-form references and repetitions of other > bindings > * fix for yamllint > > .../bindings/devfreq/rk3399_dmc.txt | 212 ------------ > .../rockchip,rk3399-dmc.yaml | 306 ++++++++++++++++++ > 2 files changed, 306 insertions(+), 212 deletions(-) > delete mode 100644 Documentation/devicetree/bindings/devfreq/rk3399_dmc.txt > create mode 100644 Documentation/devicetree/bindings/memory-controllers/rockchip,rk3399-dmc.yaml > Reviewed-by: Krzysztof Kozlowski <krzysztof.kozlowski@xxxxxxxxxxxxx> Best regards, Krzysztof