This patchset add the support of TRIMINFO_RELOAD feature for Exynos3250. But Exynos3250 has two TRIMINFO_CTRL register instead other Exynos has only one TRIMINFO_CTRL register. So, this patchset support the some Exynos SoC which has more than one TRIMINF_CTRL. Also, this patchset fix wrong value of TRIMINFO_RELOAD_SHIFT and remove duplicate code when reading triminfo register of Exynos5440. Changes from v3: - Add reviewed message of Amit Daniel Kachhap <amit.daniel@xxxxxxxxxxx> - Split RELOAD patch as two patch - Fix 'TRIMINFO_RELOAD_SHIFT' value - This series includes separate patch[1] [1] https://lkml.org/lkml/2014/8/20/5 - Drop ACTIME bit setting because TRM includes not enough information of ACTIME bit. Changes from v2: - Fix build break because of missing 'or' operation. Changes from v1: - Add missing 'TMU_SUPPORT_TRIM_RELOAD' features Chanwoo Choi (4): thermal: exynos: Fix wrong value of TRIMINFO_RELOAD_SHIFT thermal: exynos: Add support for many TRIMINFO_CTRL registers thermal: exynos: Add support for TRIM_RELOAD feature at Exynos3250 thermal: exynos: Remove duplicate code when reading triminfo register of Exynos5440 drivers/thermal/samsung/exynos_thermal_common.h | 1 + drivers/thermal/samsung/exynos_tmu.c | 27 +++++++++++++++++++------ drivers/thermal/samsung/exynos_tmu.h | 9 +++++++-- drivers/thermal/samsung/exynos_tmu_data.c | 14 +++++++++++-- drivers/thermal/samsung/exynos_tmu_data.h | 12 ++++++++--- 5 files changed, 50 insertions(+), 13 deletions(-) -- 1.8.0 -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html