On Mon, Nov 29, 2021 at 06:19:45PM +0800, allen-kh.cheng wrote: > diff --git a/drivers/mailbox/mtk-adsp-mailbox.c b/drivers/mailbox/mtk-adsp-mailbox.c [...] > +static int mtk_adsp_mbox_probe(struct platform_device *pdev) > +{ [...] > + mbox->dev = dev; > + mbox->ops = &mtk_adsp_mbox_chan_ops; > + mbox->txdone_irq = false; > + mbox->txdone_poll = true; > + mbox->of_xlate = mtk_adsp_mbox_xlate; > + mbox->num_chans = 1; > + mbox->chans = devm_kzalloc(mbox->dev, sizeof(*mbox->chans), GFP_KERNEL); I have commented in the v3[1]. To be neat, I prefer to use "dev" instead of "mbox->dev". If you ever have the chance to respin the series, please fix it. [1]: https://patchwork.kernel.org/project/linux-mediatek/patch/20211124084514.28002-3-allen-kh.cheng@xxxxxxxxxxxx/#24614933