On Mon, Nov 29, 2021 at 02:39:54PM +0800, allen-kh.cheng wrote: > From: Allen-KH Cheng <Allen-KH.Cheng@xxxxxxxxxxxx> > > This patch is to for MediaTek ADSP IPC mailbox controller driver > It is used to send short messages between processors with adsp > > Reviewed-by: Tzung-Bi Shih <tzungbi@xxxxxxxxxx> > Reviewed-by: AngeloGioacchino Del Regno<angelogioacchino.delregno@xxxxxxxxxxxxx> > Signed-off-by: Allen-KH Cheng <Allen-KH.Cheng@xxxxxxxxxxxx> Please double check again if you use the R-b tags correctly. I have provided my R-b tag before but have some more minor comments below. With the minor comments: Reviewed-by: Tzung-Bi Shih <tzungbi@xxxxxxxxxx> > diff --git a/drivers/mailbox/mtk-adsp-mailbox.c b/drivers/mailbox/mtk-adsp-mailbox.c [...] > +static const struct mbox_chan_ops adsp_mbox_chan_ops = { > + .send_data = mtk_adsp_mbox_send_data, > + .startup = mtk_adsp_mbox_startup, > + .shutdown = mtk_adsp_mbox_shutdown, > + .last_tx_done = mtk_adsp_mbox_last_tx_done, > +}; Rename adsp_mbox_chan_ops to mtk_adsp_mbox_chan_ops looks better to me.