Thanks Pierre,
On 15/09/2021 16:54, Pierre-Louis Bossart wrote:
+#define APM_SHMEM_FMT_CFG_PSIZE(n) ALIGN( \
+ sizeof(struct apm_sh_module_media_fmt_cmd) + \
+ n * sizeof(uint8_t), 8)
+
+/* num of channels as argument */
+#define APM_PCM_MODULE_FMT_CMD_PSIZE(n) ALIGN( \
+ sizeof(struct apm_pcm_module_media_fmt_cmd) + \
+ n * sizeof(uint8_t), 8)
+
+#define APM_PCM_OUT_FMT_CFG_PSIZE(n) ALIGN((sizeof( \
+ struct payload_pcm_output_format_cfg) + \
+ n * sizeof(uint8_t)), 4)
nit-pick: sizeof on the same line for consistency/readability?
Its fixed in next version.
--srini