On 06.09.21 20:43, Lucas Stach wrote: > This adds the defines for the power domains provided by the VPU > blk-ctrl. > > Signed-off-by: Lucas Stach <l.stach@xxxxxxxxxxxxxx> > --- > include/dt-bindings/power/imx8mm-power.h | 4 ++++ > 1 file changed, 4 insertions(+) > > diff --git a/include/dt-bindings/power/imx8mm-power.h b/include/dt-bindings/power/imx8mm-power.h > index fc9c2e16aadc..38b0a56fd7d0 100644 > --- a/include/dt-bindings/power/imx8mm-power.h > +++ b/include/dt-bindings/power/imx8mm-power.h > @@ -19,4 +19,8 @@ > #define IMX8MM_POWER_DOMAIN_DISPMIX 10 > #define IMX8MM_POWER_DOMAIN_MIPI 11 > > +#define IMX8MM_VPUBLK_PD_G1 0 > +#define IMX8MM_VPUBLK_PD_G2 1 > +#define IMX8MM_VPUBLK_PD_H1 2 I wonder how these defines should be named. Here you have a IMX8MM_*BLK_PD_*, but for the DISP BLK-CTRL you only have IMX8MM_*BLK_* (without the PD). Also in Peng's last approach for this we already have defines for this [1] that have been acked by Rob and might be useful as a reference or you could even pick up Peng's patch and by that carry over the existing R-b/A-b tags. Though, in general I like the shorter versions you provided better. [1] https://patchwork.kernel.org/project/linux-arm-kernel/patch/20210629072941.7980-2-peng.fan@xxxxxxxxxxx/ > + > #endif >