Hi, This series adds support for Rx mode on Cadence DPHY driver. It has been split off from [0] to facilitate easier merging. I have still kept the version number to maintain continuity with the previous patches. This series also includes conversion to YAML binding. Tested on TI's J721E with OV5640 sensor. [0] https://patchwork.linuxtv.org/project/linux-media/list/?series=5526&state=%2A&archive=both Changes in v5: - Based on Laurent's suggestion, add cdns_dphy_info which contains the phy_ops and cdns_dphy_tx_ops (renamed from cdns_dphy_ops). This lets us get rid of the phy ops wrappers. - Move probe() and remove() into cdns_dphy_common_ops() since they can be used by both modes. Drop the check in power_on(). - Get the clocks in the tx ops probe to make sure they are mandatory for Tx mode but not for Rx mode. - Use the new cdns_dphy_info to specify PHY ops. - Re-order include in alphabetical order. - Make bands const. - Drop num_bands. - Make i, lanes unsigned. - Drop the maximum check in cdns_dphy_rx_get_band_ctrl(). Let the loop complete and return -EOPNOTSUPP when we reach the end. - Drop the "rate < bands[i].min_rate" check since the bands are in ascending order. - Move data_lane_ctrl to start of function and make it static const. - Make clocks a required property based on the compatible. - Use enum instead. Changes in v4: - Instead of having both Rx and Tx modes in the same driver data, keep them separate since the op selection is based on compatible now. For that reason, the cdns_dphy_driver_data struct is no longer needed. - Rename ref_dphy_ops to tx_ref_dphy_ops to clarify their purpose. - Drop submode checks in validate() hook. - Drop the submode parts. Use a different compatible for the Rx ops. - Make bands and num_bands static. - Drop the submode patches. Use a different compatible for Rx mode DPHY instead. Changes in v3: - Use a table to select the band. - Use a table to poll the data lane ready bits. - Multiply the DPHY HS clock rate by 2 to get the bit rate since the clock is DDR. - Add Rob's R-by. Changes in v2: - Drop reg description. - Add a description for each DPHY clock. - Rename dphy@... to phy@... in example. - Add Laurent's R-by. - Re-order subject prefixes. - Re-order subject prefixes. - Add power-domain to the example. - Add Laurent's R-by. - Re-order subject prefixes. Pratyush Yadav (6): phy: cdns-dphy: Prepare for Rx support phy: cdns-dphy: Add Rx support phy: dt-bindings: Convert Cadence DPHY binding to YAML phy: dt-bindings: cdns,dphy: make clocks optional for Rx mode phy: dt-bindings: cdns,dphy: add power-domains property phy: dt-bindings: cdns,dphy: add Rx DPHY compatible .../devicetree/bindings/phy/cdns,dphy.txt | 20 - .../devicetree/bindings/phy/cdns,dphy.yaml | 66 ++++ drivers/phy/cadence/cdns-dphy.c | 351 +++++++++++++++--- 3 files changed, 356 insertions(+), 81 deletions(-) delete mode 100644 Documentation/devicetree/bindings/phy/cdns,dphy.txt create mode 100644 Documentation/devicetree/bindings/phy/cdns,dphy.yaml -- 2.33.0