On Mon, Aug 30, 2021 at 1:48 PM Alejandro Tafalla <atafalla@xxxxxxxxx> wrote: > > Drive the reset gpio if defined in the DTS node. ... > + reset_gpio > + = devm_gpiod_get_optional(&i2c->dev, "reset", GPIOD_OUT_LOW); A bit of a strange indentation, shouldn't it be one line? > + if (IS_ERR(reset_gpio)) { > + ret = PTR_ERR(reset_gpio); > + return dev_err_probe(&i2c->dev, ret, > + "failed to request GPIO reset pin"); It simply as return dev_err_probe(&i2c->dev, PTR_ERR(reset_gpio), "failed to request GPIO reset pin"); > + } -- With Best Regards, Andy Shevchenko