On Fri, Jul 23, 2021 at 9:59 AM Andrew Jeffery <andrew@xxxxxxxx> wrote: > Allow gpiochips to map the GPIO numberspace onto a pin numberspace when > the register layout for GPIO control is implemented in terms of the > pin numberspace. > > This requirement sounds kind of strange, but the patch is driven by > trying to resolve a bug in the leds-pca955x driver where this mapping is > not correctly performed. > > Signed-off-by: Andrew Jeffery <andrew@xxxxxxxx> (...) Hm this looks a bit strange... > +int pinctrl_gpio_as_pin(struct pinctrl_dev *pctldev, unsigned int gpio) This is not a good name for this function. Try to come up with a name that says exactly what the function does. E.g. "apple pear as apple slice" isn't very helpful, the use case for this is really hard to understand. > +EXPORT_SYMBOL_GPL(pinctrl_find_gpio_range_from_pin); This looks completely wrong. Yours, Linus Walleij