Re: [PATCH v5 1/5] iio: adc: ad7949: define and use bitfield names

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sun Aug 8, 2021 at 12:51 PM EDT, Joe Perches wrote:
> On Sat, 2021-08-07 at 21:56 -0400, Liam Beguin wrote:
> > Replace raw configuration register values by using FIELD_PREP and
> > defines to improve readability.
> []
> > diff --git a/drivers/iio/adc/ad7949.c b/drivers/iio/adc/ad7949.c
> []
> +#define AD7949_CFG_BIT_INCC GENMASK(12, 10)
>

Hi Joe,

> I think the naming is a bit confusing as it appears as if
> these bitfield ranges are single bits.

That makes sense.
Would AD7949_CFG_BITS_* be good enough?

Thanks,
Liam

>
> > +/* REF: reference/buffer selection */
> > +#define AD7949_CFG_BIT_REF		GENMASK(5, 3)
> []
> > +/* SEQ: channel sequencer. Allows for scanning channels */
> > +#define AD7949_CFG_BIT_SEQ		GENMASK(2, 1)
> > 





[Index of Archives]     [Device Tree Compilter]     [Device Tree Spec]     [Linux Driver Backports]     [Video for Linux]     [Linux USB Devel]     [Linux PCI Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Yosemite Backpacking]


  Powered by Linux