On Thu, 01 Jul 2021 23:03:28 +0900, 권오훈 wrote: > In __of_get_next_child function, loop iteration for getting next node is > unnecessary. > > for loop is already checking if next is NULL or not, and > of_node_get(next) always returns next itself. > > Therefore checking return value in the if clause always evaluates to > true, and thus it always breaks out from for loop in the first iteration. > > Remove the unnecessary for loop for readability. > > I tested the code as below, and it showed that BUG was never called. > > - for (; next; next = next->sibling) > + for (; next; next = next->sibling) { > if (of_node_get(next)) > break; > + BUG(); > + } > > Signed-off-by: Ohhoon Kwon <ohoono.kwon@xxxxxxxxxxx> > --- > drivers/of/base.c | 4 +--- > 1 file changed, 1 insertion(+), 3 deletions(-) > Applied, thanks!