Re: [PATCH v3 01/14] gpio: regmap: set gpio_chip of_node

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Am 2021-03-03 15:22, schrieb Álvaro Fernández Rojas:
This is needed for properly registering gpio regmap as a child of a regmap
pin controller.

Signed-off-by: Álvaro Fernández Rojas <noltari@xxxxxxxxx>
---
 v3: introduce patch needed for properly parsing gpio-ranges.

 drivers/gpio/gpio-regmap.c  | 1 +
 include/linux/gpio/regmap.h | 3 +++
 2 files changed, 4 insertions(+)

diff --git a/drivers/gpio/gpio-regmap.c b/drivers/gpio/gpio-regmap.c
index 5412cb3b0b2a..752ccd780b7d 100644
--- a/drivers/gpio/gpio-regmap.c
+++ b/drivers/gpio/gpio-regmap.c
@@ -249,6 +249,7 @@ struct gpio_regmap *gpio_regmap_register(const
struct gpio_regmap_config *config

 	chip = &gpio->gpio_chip;
 	chip->parent = config->parent;
+	chip->of_node = config->of_node;

chip->of_node = config->of_node ?: dev_of_node(config->parent);

As mentioned in my previous reply in this thread, for clarity
reasons.

 	chip->base = -1;
 	chip->ngpio = config->ngpio;
 	chip->names = config->names;
diff --git a/include/linux/gpio/regmap.h b/include/linux/gpio/regmap.h
index ad76f3d0a6ba..f6e638e32d2a 100644
--- a/include/linux/gpio/regmap.h
+++ b/include/linux/gpio/regmap.h
@@ -4,6 +4,7 @@
 #define _LINUX_GPIO_REGMAP_H

 struct device;
+struct device_node;
 struct gpio_regmap;
 struct irq_domain;
 struct regmap;
@@ -14,6 +15,7 @@ struct regmap;
 /**
* struct gpio_regmap_config - Description of a generic regmap gpio_chip.
  * @parent:		The parent device
+ * @of_node:		The device node

Please add "(Optional)" and move it below @regmap. This should also
mention that if not supplied parent->of_node is used.

  * @regmap:		The regmap used to access the registers
  *			given, the name of the device is used
  * @label:		(Optional) Descriptive name for GPIO controller.
@@ -56,6 +58,7 @@ struct regmap;
  */
 struct gpio_regmap_config {
 	struct device *parent;
+	struct device_node *of_node;
 	struct regmap *regmap;

 	const char *label;

With these changes:
Reviewed-by: Michael Walle <michael@xxxxxxxx>

-michael



[Index of Archives]     [Device Tree Compilter]     [Device Tree Spec]     [Linux Driver Backports]     [Video for Linux]     [Linux USB Devel]     [Linux PCI Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Yosemite Backpacking]


  Powered by Linux