wt., 5 maj 2020 o 19:31 Jakub Kicinski <kuba@xxxxxxxxxx> napisał(a): > > On Tue, 5 May 2020 16:02:25 +0200 Bartosz Golaszewski wrote: > > From: Bartosz Golaszewski <bgolaszewski@xxxxxxxxxxxx> > > > > Provide devm_register_netdev() - a device resource managed variant > > of register_netdev(). This new helper will only work for net_device > > structs that have a parent device assigned and are devres managed too. > > > > Signed-off-by: Bartosz Golaszewski <bgolaszewski@xxxxxxxxxxxx> > > > diff --git a/net/core/dev.c b/net/core/dev.c > > index 522288177bbd..99db537c9468 100644 > > --- a/net/core/dev.c > > +++ b/net/core/dev.c > > @@ -9519,6 +9519,54 @@ int register_netdev(struct net_device *dev) > > } > > EXPORT_SYMBOL(register_netdev); > > > > +struct netdevice_devres { > > + struct net_device *ndev; > > +}; > > Is there really a need to define a structure if we only need a pointer? > There is no need for that, but it really is more readable this way. Also: using a pointer directly doesn't save us any memory nor code here. Bart