Hi, On Mon, Feb 17, 2020 at 11:52 AM Ran Bi <ran.bi@xxxxxxxxxxxx> wrote: > > On Tue, 2020-02-04 at 00:50 +0800, Yingjoe Chen wrote: > > > diff --git a/include/linux/mfd/mt6397/rtc.h b/include/linux/mfd/mt6397/rtc.h > > > index f84b916..fffe34a 100644 > > > --- a/include/linux/mfd/mt6397/rtc.h > > > +++ b/include/linux/mfd/mt6397/rtc.h > > > @@ -18,7 +18,8 @@ > > > #define RTC_BBPU_CBUSY BIT(6) > > > #define RTC_BBPU_KEY (0x43 << 8) > > > > > > -#define RTC_WRTGR 0x003c > > > +#define RTC_WRTGR_MT6358 0x3a > > > +#define RTC_WRTGR_MT6397 0x3c > > > > > > #define RTC_IRQ_STA 0x0002 > > > #define RTC_IRQ_STA_AL BIT(0) > > > @@ -57,6 +58,10 @@ > > > #define MTK_RTC_POLL_DELAY_US 10 > > > #define MTK_RTC_POLL_TIMEOUT (jiffies_to_usecs(HZ)) > > > > > > +struct mtk_rtc_data { > > > + u32 wrtgr; > > > +}; > > > + > > > struct mt6397_rtc { > > > struct device *dev; > > > struct rtc_device *rtc_dev; > > > @@ -66,6 +71,15 @@ struct mt6397_rtc { > > > struct regmap *regmap; > > > int irq; > > > u32 addr_base; > > > + const struct mtk_rtc_data *data; > > > +}; > > > + > > > +static const struct mtk_rtc_data mt6358_rtc_data = { > > > + .wrtgr = RTC_WRTGR_MT6358, > > > +}; > > > + > > > +static const struct mtk_rtc_data mt6397_rtc_data = { > > > + .wrtgr = RTC_WRTGR_MT6397, > > > }; > > > > Hi, > > > > Putting these in header file doesn't looks right to me. > > Who need this? can you move them back to rtc-mt6397.c? > > Joe.C > > > > This could also effect kernel/drivers/power/reset/mt6323-poweroff.c > which using same region of RTC registers. > There are 2 ways of modification: > 1. kernel/drivers/rtc/rtc-mt6397.c implement do_pwroff function and > export to mt6323-poweroff.c > 2. Just modify mt6323-poweroff.c file to compatible this patch. I mean > using RTC_WRTGR_MT6397 to replace RTC_WRTGR. Or modify mt6323-poweroff.c > like rtc-mt6397.c Oh, I see, so basically both rtc-mt6397.c and mt6323-poweroff.c need to know at what offset RTC_WRTGR actually is. Correct? Is there any plan to have mt6323-poweroff.c support any of the other PMICs (not just MT6323?)? a. If not, I'd just add: #define RTC_WRTGR_MT6323 RTC_WRTGR_MT6397 in rtc.h, for added clarity, use that in mt6323-poweroff.c (s/RTC_WRTGR/RTC_WRTGR_MT6323/), and be done with it. Actually, even if there's a plan, you can go ahead with this simpler solution for now, and fix later when the issue comes up. b. If you ever want to support multiple PMICs with mt6323-poweroff.c, you'd need that offset for 2 different sub-devices under the same mfd, so the matching logic belongs in the main mfd device, not in rtc/poweroff driver. So I'd move the matching logic in drivers/mfd/mt6397-core.c, and add rtc_wrtgr offset (or a full _data structure) to `struct mt6397_chip`, or, probably better, add a IORESOURCE_REG to the matching resources to specify the offset (that's what drivers/mfd/88pm860x-core.c seems to be doing, for example). And then mt6323-poweroff.c should probably be renamed to mt6397-poweroff.c. (actually, looking at this, I'm even questioning if mt6323-poweroff.c should even exist, and if you should just fold it into rtc-mt6397.c? Since they use the same registers?) Hope this makes sense? Best,