On 3/27/2019 3:17 PM, Wolfram Sang wrote: > >> + if (!((readl(iproc_i2c->base + >> + M_FIFO_CTRL_OFFSET) >> >> + M_FIFO_RX_CNT_SHIFT) & >> + M_FIFO_RX_CNT_MASK)) > > Don't be too strict with the 80 char limit. I think the above is hardly > readable... > Right, that makes sense. Will change to make it more readable than trying to be compliant to the < 80 chars rule. >> + break; >> + >> + msg->buf[iproc_i2c->rx_bytes] = >> + (readl(iproc_i2c->base + M_RX_OFFSET) >> >> + M_RX_DATA_SHIFT) & M_RX_DATA_MASK; > > ... this here is MUCH better. > > Rest looks good. > Thanks, Ray