Hi Matthias, On Tue, Mar 19, 2019 at 05:33:52PM -0700, Matthias Kaehlcke wrote: > ... > > @@ -95,6 +103,19 @@ static int rk3399_dmcfreq_target(struct device *dev, unsigned long *freq, > > > > mutex_lock(&dmcfreq->lock); > > > > + if (target_rate >= dmcfreq->odt_dis_freq) > > + odt_enable = true; > > + > > + /* > > + * This makes a SMC call to the TF-A to set the DDR PD (power-down) > > + * timings and to enable or disable the ODT (on-die termination) > > + * resistors. > > + */ > > + arm_smccc_smc(ROCKCHIP_SIP_DRAM_FREQ, dmcfreq->odt_pd_arg0, > > + dmcfreq->odt_pd_arg1, > > + ROCKCHIP_SIP_CONFIG_DRAM_SET_ODT_PD, > > + odt_enable, 0, 0, 0, &res); > > Is it necessary/desirable to make this call for every frequency > change? IIUC it should be only needed when odt_enable changes and the > driver could track the state. If the DDR frequency doesn't change too > often and the overhead of the call is small it shouldn't be really > important though. > I will test your solution first to make sure there is no regression to run that call for frequency change only. Also, the call takes around 300us. > > ... > > @@ -334,6 +357,34 @@ static int rk3399_dmcfreq_probe(struct platform_device *pdev) > > return ret; > > } > > > > + /* Try to find the optional reference to the pmu syscon */ > > + node = of_parse_phandle(np, "rockchip,pmu", 0); > > + if (node) { > > The 'optional' part doesn't seem to be accurate: according to the > binding (https://lore.kernel.org/patchwork/patch/1052322/) the > property is required and the code below assumes that data->regmap_pmu > is set. > Indeed. > > + data->regmap_pmu = syscon_node_to_regmap(node); > > + if (IS_ERR(data->regmap_pmu)) > > + return PTR_ERR(data->regmap_pmu); > > + } > > + > > + /* Get DDR type */ > > nit: the comment doesn't add much value, thanks to good variable > naming this is evident from the code. > > > + regmap_read(data->regmap_pmu, RK3399_PMUGRF_OS_REG2, &val); > > + ddr_type = (val >> RK3399_PMUGRF_DDRTYPE_SHIFT) & > > + RK3399_PMUGRF_DDRTYPE_MASK; > > + > > + /* Get the odt_dis_freq parameter in function of the DDR type */ > > nit: ditto > > (if you prefer to keep these comments I'm not opposed to keeping them, > but I don't think they are needed) > I will remove all the comments in the v3. > Cheers > > Matthias > > _______________________________________________ > Linux-rockchip mailing list > Linux-rockchip@xxxxxxxxxxxxxxxxxxx > http://lists.infradead.org/mailman/listinfo/linux-rockchip Regards, Gaël