On Thu, Jan 10, 2019 at 06:58:41PM +0100, Lubomir Rintel wrote: > It's based off the driver from the OLPC kernel sources. Somewhat > modernized and cleaned up, for better or worse. > > Modified to plug into the olpc-ec driver infrastructure (so that battery > interface and debugfs could be reused) and the SPI slave framework. > > Signed-off-by: Lubomir Rintel <lkundrak@xxxxx> > > --- > Changes since v4: > - Chop off the reboot handler. Will be added back once it's clear how. > > Changes since v3: > - Introduce CONFIG_OLPC_EC symbol to enable parts common to this driver > and the X86 OLPC EC machinery. > > Changes since v1: > - Cosmetic style changes; whitespace, ordering of declarations and > #includes, remoted extra comas from sentinels > - Count the terminating NUL in LOG_BUF_SIZE > - Make olpc_xo175_ec_is_valid_cmd() return -EINVAL instead of -1 > on error > - Spell keyboard/touchpad in full for CHAN_KEYBOARD/TOUCHPAD messages > - Use a #define for PM wakeup processing time > - Log a message on unknown event > - Escape logging payload with %*pE > - Replace an open-coded min() > - Correct an error code on short read > - replaced PM callback #ifdefs with __maybe_unusedm SET_RUNTIME_PM_OPS > and SET_NOIRQ_SYSTEM_SLEEP_PM_OPS > - dev_get_drvdata() instead of a round-trip through platform device > - s/unsigned char x/u8 x/ in olpc_xo175_ec_resume() > - Use GENMASK() instead of 0xffff for the event mask > - Replace cmd tx/resp rx buffers with structures > - Turned suspend hint arguments into a struct, and tidied up the comment > > Basically all of the above is based on the review by Andy Shevchenko. Andy, I am happy to merge this series - but this patch includes a lot of changes driven by your feedback. Are you satisfied with the changes, would you like to add your Reviewed-by? -- Darren Hart VMware Open Source Technology Center