Re: [PATCH v5 4/8] ASoC: wcd9335: add basic controls

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Thanks for the review,

On 22/01/2019 18:52, Mark Brown wrote:
On Thu, Jan 10, 2019 at 03:06:12PM +0000, Srinivas Kandagatla wrote:

+static const char * const wcd9335_ear_pa_gain_text[] = {
+	"G_6_DB", "G_4P5_DB", "G_3_DB", "G_1P5_DB",
+	"G_0_DB", "G_M2P5_DB", "UNDEFINED", "G_M12_DB"
+};

Gains should be controlled with Volume controls, not enums.  Provide
information on the levels via TLV.
I agree, I will fix this as well in next version!

+static const char * const rx_hph_mode_mux_text[] = {
+	"CLS_H_INVALID", "CLS_H_HIFI", "CLS_H_LP", "CLS_AB", "CLS_H_LOHIFI"
+};

Is there a strong reason not to use more human readable strings here?

No, I can rename them to below if it helps reader.

"Class-H Hi-Fi", "Class-H Low Power", "Class-AB", "Class-H Hi-Fi Low Power".

Thanks,
srini



[Index of Archives]     [Device Tree Compilter]     [Device Tree Spec]     [Linux Driver Backports]     [Video for Linux]     [Linux USB Devel]     [Linux PCI Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Yosemite Backpacking]


  Powered by Linux