On Mon, Jan 07, 2019 at 01:55:42PM -0800, Stephen Boyd wrote: > > + ret = pmic_gpio_domain_translate(domain, fwspec, &hwirq, &type); > > + if (ret) > > + return ret; > > + > > + for (i = 0; i < nr_irqs; i++) > > + irq_domain_set_info(domain, virq + i, hwirq + i, > > + &pmic_gpio_irq_chip, state, > > + handle_level_irq, NULL, NULL); > > + > > + parent_fwspec.fwnode = domain->parent->fwnode; > > + parent_fwspec.param_count = 4; > > + parent_fwspec.param[0] = 0; > > + parent_fwspec.param[1] = fwspec->param[0] + 0xc0 - 1; > > Is the -1 there twice, once in pmic_gpio_domain_translate() and then > here? That should be 'hwirq + c0' to improve the code readability. Brian