On Fri, 2018-12-21 at 18:47 +0100, Matthias Brugger wrote: > > On 08/12/2018 09:39, Yong Wu wrote: > > The config_port of mt2712 and mt8183 are the same. Use a general > > config_port interface instead. > > > > In addition, in mt2712, larb8 and larb9 are the bdpsys larbs which > > are not the normal larb, their register space are different from the > > normal one. thus, we can not call the general config_port. In mt8183, > > IPU0/1 and CCU connect with smi-common directly, they also are not > > the normal larb. Hence, we add a "larb_special_mask" for these special > > larbs. > > > > This is also a preparing patch for adding mt8183 SMI support. > > > > Signed-off-by: Yong Wu <yong.wu@xxxxxxxxxxxx> > > --- > > drivers/memory/mtk-smi.c | 12 +++++------- > > 1 file changed, 5 insertions(+), 7 deletions(-) > > > > diff --git a/drivers/memory/mtk-smi.c b/drivers/memory/mtk-smi.c > > index 8f2d152..3b9ad0e 100644 > > --- a/drivers/memory/mtk-smi.c > > +++ b/drivers/memory/mtk-smi.c > > @@ -53,6 +53,7 @@ struct mtk_smi_larb_gen { > > bool need_larbid; > > int port_in_larb[MTK_LARB_NR_MAX + 1]; > > void (*config_port)(struct device *); > > + unsigned int larb_special_mask; /* The special larbs mask. */ > > I'm not really happy with the name larb_special_mask but I can't think of > anything else. The comment is not needed as it just rewords the name of the > variable. Thanks this comment. then I reword more detail instead this common "special", How about "larb_to_common_directly_mask"? > > Other then that (or even without changing anything): > > Reviewed-by: Matthias Brugger <matthias.bgg@xxxxxxxxx> Thanks. > > > }; > > > > struct mtk_smi { > > @@ -176,17 +177,13 @@ void mtk_smi_larb_put(struct device *larbdev) > > return -ENODEV; > > } > > > > -static void mtk_smi_larb_config_port_mt2712(struct device *dev) > > +static void mtk_smi_larb_config_port_gen2_general(struct device *dev) > > { > > struct mtk_smi_larb *larb = dev_get_drvdata(dev); > > u32 reg; > > int i; > > > > - /* > > - * larb 8/9 is the bdpsys larb, the iommu_en is enabled defaultly. > > - * Don't need to set it again. > > - */ > > - if (larb->larbid == 8 || larb->larbid == 9) > > + if (BIT(larb->larbid) & larb->larb_gen->larb_special_mask) > > return; > > > > for_each_set_bit(i, (unsigned long *)larb->mmu, 32) { > > @@ -261,7 +258,8 @@ static void mtk_smi_larb_config_port_gen1(struct device *dev) > > > > static const struct mtk_smi_larb_gen mtk_smi_larb_mt2712 = { > > .need_larbid = true, > > - .config_port = mtk_smi_larb_config_port_mt2712, > > + .config_port = mtk_smi_larb_config_port_gen2_general, > > + .larb_special_mask = BIT(8) | BIT(9), /* bdpsys */ > > }; > > > > static const struct of_device_id mtk_smi_larb_of_ids[] = { > >