Thanks for your comments!
On 16/11/18 07:18, Daniel Baluta wrote:
One minor comment:
<snip>
struct snd_compr_ops *ops;
+ struct snd_dma_buffer *dma_buffer_p;
I don't think it is necessary to encode the type inside the name variable
So, dma_buffer would sounds better to me then dma_buffer_p;
void *buffer;
It is also consistent with this ^
<snip>
+static inline void snd_compr_set_runtime_buffer(
+ struct snd_compr_stream *substream,
+ struct snd_dma_buffer *bufp)
Also buf instead of bufp here.
TBH, I followed what ./include/sound/pcm.h does!
--srini