On 24/02/14 01:43, Mike Turquette wrote: [...] >> > +/** >> > + * of_clk_get_list_entry() - Parse and lookup a clock referenced by a device node >> > + * @np: pointer to clock consumer node >> > + * @list_name: name of the clock list property >> > + * @index: index to the clock list >> > + * >> > + * This function parses the @list_name property and together with @index >> > + * value indicating an entry of the list uses it to look up the struct clk >> > + * from the registered list of clock providers. >> > + */ >> > +struct clk *of_clk_get_list_entry(struct device_node *np, >> > + const char *list_name, int index) > > Bikeshed alert: how about of_clk_get_by_property or of_clk_get_by_prop? That sounds better to me, thanks for the suggestion. For the next iteration I'm going to use of_clk_get_by_property() . Regards, Sylwester -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html