On Thu, 2018-03-22 at 18:26 +0100, Paolo Pisati wrote: > > It's frequently nicer to use a static function > > for these enum -> string conversions like: > > > > static const char *get_err_string(unsigned long err) > > { > > switch (err) { > > case ENOERR: return "No Error"; > > case EID: return "ID ERR"; > > case ECMD: return "CMD ERR"; > > [...] > > } > > return "default switch case"; > > } > > Ok - checkpatch complained when i put the "case ...: return ...;" on the same > line as you did here, that is why i ended up with the ugly "case...: $string; > break" all on different lines checkpatch is brainless and stupid and if it recommends stupid consistency over readability, ignore it. > > > + pr_debug("machxo2 status: 0x%08lX - done=%d, cfgena=%d, busy=%d, fail=%d, devver=%d, err=%s\n", > > > + *status, test_bit(DONE, status), test_bit(ENAB, status), > > > + test_bit(BUSY, status), test_bit(FAIL, status), > > > + test_bit(DVER, status), ferr); > > > > So instead of ferr, this could use > > get_err_string(*status) > > > > And please try to keep a consistent alignment for > > indentation of multiple line statements > > I tried, but then checkpatch complained again about the indentation of the above block > and i literally had to guess... I think it only complained about the 2nd line that starts *status because it doesn't align with the open parenthesis of pr_debug -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html