From: Frank Rowand <frank.rowand@xxxxxxxx> I have found the device tree overlay code to be difficult to read and maintain. This patch series attempts to improve that situation. The cleanup includes some changes visible to users of overlays. The only in kernel user of overlays is fixed up for those changes. The in kernel user is: drivers/gpu/drm/tilcdc/tilcdc_slave_compat.c Following the cleanup patches are a set of patches to fix various issues. The first five patches are intended to not make any functional changes, and are segrated to ease review. Frank Rowand (12): of: overlay.c: Remove comments that state the obvious, to reduce clutter of: overlay.c: Convert comparisons to zero or NULL to logical expressions of: overlay: rename identifiers to more reflect what they do of: overlay: rename identifiers in dup_and_fixup_symbol_prop() of: overlay: minor restructuring of: overlay: detect cases where device tree may become corrupt of: overlay: expand check of whether overlay changeset can be removed of: overlay: loosen overly strict phandle clash check of: overlay: avoid race condition between applying multiple overlays of: overlay: simplify applying symbols from an overlay of: overlay: remove a dependency on device node full_name of: overlay: remove unneeded check for NULL kbasename() Documentation/devicetree/overlay-notes.txt | 12 +- drivers/gpu/drm/tilcdc/tilcdc_slave_compat.c | 14 +- drivers/of/base.c | 2 +- drivers/of/dynamic.c | 137 +++- drivers/of/of_private.h | 22 +- drivers/of/overlay.c | 1034 ++++++++++++++++---------- drivers/of/resolver.c | 7 + drivers/of/unittest.c | 81 +- include/linux/of.h | 17 +- 9 files changed, 869 insertions(+), 457 deletions(-) -- Frank Rowand <frank.rowand@xxxxxxxx> -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html